Forum has been created to help all our customers in properly working our theme. We offer complete help with configuration theme and make default look, just like on our Be|theme demo. We don`t offer theme customization.


Before creating a new discussion, please:
1. Check on forum if discussion hasn`t been created before. Use the forum Search on the right.
2. Read carefully the documentation included to package.
3. If you didn`t find what you need and would like to post a new question click the "Start a New Discussion" button on the right.
4. You can post on forum only after registration (you need purchase code to register) .


NOTE!!! If you are starting a new topic and have got problems with your site and you want us to check what`s wrong please always give url to your site because without that we can`t check what`s wrong. Each case may be different because of your installed plugins, servers or other things.


IMPORTANT!!! Along with your inquiry, please attach the address of the page which concerns the question. This will cause the time to answer on your question will be much shorter. If you do not want to publish your address publicly in the forum, please send a private message. Thanks!

Youtube background video stopped working

Hi there, 

I've implemented a background video which worked untill recently:
I checked Google's developer's guidelines and the videos are muted so that should be fine.. https://developers.google.com/web/updates/2017/09/autoplay-policy-changes

Could you please check and advise?

Many thanks in advance.

Kind regards,

Tim

Comments

  • Please sign in to see answear!
  • Hi, 

    Thanks for your prompt reply. 
    I tried disabling other plugins but it does not help. 

    The issue is in Chrome, not firefox and seems to be related to this:
    Failed to execute 'postMessage' on 'DOMWindow': The target origin provided ('https://www.youtube.com') does not match the recipient window's origin ('https://global.clb.nl').

    Do you know how to fix this?

    Meanwhile I'll look at the HTML flaws.

    Thanks.
  • Nevermind, the issue has been fixed..

    Regards,

    Tim
  • edited June 19
    Hello, I've being having the same problem
    Background Video in Revslider, Chrome, not working
    Works fine on Firefox and it used to work before.

    Updated the Theme and the plugin (5.4.7.4), disabled all other plugins, switch theme to test, nothing happens,

    The video is loading with the iframe having opacity: 0 and visibility: hidden, no autoplay.

    (Look here, the slider is at the top)

    Site is hosted on FastComet, PHP version 7.0. if it 

    Please help.

    *** Update 1: Vimeo is working fine, just Youtube is not running
    *** Update 2: On Android it's OK, Chrome on PC is the 
  • edited June 20
    Please sign in to see answear!
  • Hello Pablo and thank you for you response.

    It's good to know that soon browsers will block autoplay videos, it's an issue with this client.
    I advised against it but he insists, and with sound... so we have to make it work and worry about it later when browsers will make the decisions for him I guess... 
      
    Since this is a background video and not a video layer, the second link is irrelevant.
    I don't know how to remove this param, it's not in the arguments field, I actually cleared all arguments now and I still see enablejsapi=1 when I inspect the slider, is there a global setting for this parameter?
  • Please sign in to see answear!
  • Thank you for your help. unfortunately the issue was not resolved and I'm lost here, I'll use Vimeo instead, this is taking too long :-/

    Thanks again,
    Guy
Sign In or Register to comment.