Forum has been created to help all our customers in properly working our theme. We offer complete help with configuration theme and make default look, just like on our Tisson demo. We don`t offer theme customization.

Before creating a new discussion, please:
1. Check on forum if discussion hasn`t been created before. Use the forum Search on the right.
2. Read carefully the documentation included to package.
If you didn`t find what you need and would like to post a new question click the "Start a New Discussion" button on the right.
4. You can post on forum only after registration (you need purchase code to register) .


NOTE!!! If you are starting a new topic and have got problems with your site and you want us to check what`s wrong please always give url to your site because without that we can`t check what`s wrong. Each case may be different because of your installed plugins, servers or other things.

Tisson: PHP7 problem
  • On the old server (php 5.6) had no problems.
    After the migration to the new server I see this warning:

    Warning
    : Declaration of New_Walker_Category::start_el(&$output, $category, $depth, $args) should be compatible with Walker_Category::start_el(&$output, $category, $depth = 0, $args = Array, $id = 0) in /home/.../.../.../public_html/wp-content/themes/tisson/functions/theme-functions.php on line 216
  • 3 Comments sorted by
  • Hi,

    I have updated my hosting to PHP7, using wordpress 4.8 and Tisson theme Versión: 1.2.2, and it goes down.

    I have run the plugin "PHP Compatibility" and I get some results about Tisson theme:
    - tisson/functions/widget-call-to-action.php; tisson/functions/widget-contact-box.php; tisson/functions/widget-flickr.php; tisson/functions/widget-menu.php; tisson/functions/widget-recent-comments.php; tisson/functions/widget-recent-posts.php; tisson/functions/widget-tag-cloud.php
     16 | WARNING | Use of deprecated PHP4 style class constructor is not supported since PHP 7.

    -tisson/functions/widget-twitter.php
     16 | WARNING | Use of deprecated PHP4 style class constructor is not supported since PHP 7.
     55 | ERROR   | preg_replace() - /e modifier is deprecated since PHP 5.5 and removed since PHP 7.0

    Could you please help me how to solve this?
    Thank you.

    Kind regards.