Forum has been created to help all our customers in properly working our theme. We offer complete help with configuration theme and make default look, just like on our Rocco demo. We don`t offer theme customization.

Before creating a new discussion, please:
1. Check on forum if discussion hasn`t been created before. Use the forum Search on the right.
2. Read carefully the documentation included to package.
If you didn`t find what you need and would like to post a new question click the "Start a New Discussion" button on the right.
4. You can post on forum only after registration (you need purchase code to register) .


NOTE!!! If you are starting a new topic and have got problems with your site and you want us to check what`s wrong please always give url to your site because without that we can`t check what`s wrong. Each case may be different because of your installed plugins, servers or other things.


Theme conflict with Plugin in theme-head.php
  • I had a "conflict" with a form plug in, but as it turns out its actually a theme issue. As explained by plugin developer:
    The theme is not following WP standards. They are including there own scripts and not the scripts that wordpress provides.
    For example:
    wp_enqueue_script( 'jquery-ui-core', THEME_URI .'/js/ui/jquery.ui.core.js', false, THEME_VERSION, true );
    Should be:
    wp_enqueue_script( 'jquery-ui-core');

    They can obviously include there own scripts but those that are in the wordpress directory should be included from the Wordpress directory and not any other location. That's WordPress's rules by the way not mine and as you can now see there is a very good reason for it :)

    --
    I'm not 100% sure of what that means and more importantly how to fix it? Is it just a simple syntax issue? What's the work around to correct this?
    When I take out this one line of code, the plugin works fine, (theme-head.php on line 162):
    add_action('wp_enqueue_scripts', 'mfn_scripts');

    Thanks!

  • 4 Comments sorted by
  • Please sign in to see answear!
  • OK well that's fine. I tested the plugin on many themes now, and Rocco is the only theme that breaks the plugin and its this line:
    add_action('wp_enqueue_scripts', 'mfn_scripts'); in theme-head.php


    Can you explain and provide a solution?

    When I remove the 1 line of code, the 1 obvious thing that stops working is the drop-down Navigation menu when the theme is viewed on a mobile device. Not sure what else is effected. Please advice. I've spend a week on trying to get some answers on this now. Thanks!!
  • Please sign in to see answear!
  • Terrible! Tested on over 20 themes, Rocco is the only one this plugin fails to work with.