Forum has been created to help all our customers in properly working our theme. We offer complete help with configuration theme and make default look, just like on our Be|theme demo. We don`t offer theme customization.

Before creating a new discussion, please:
1. Check on forum if discussion hasn`t been created before. Use the forum Search on the right.
2. Read carefully the documentation included to package.
3. If you didn`t find what you need and would like to post a new question click the "Start a New Discussion" button on the right.
4. You can post on forum only after registration (you need purchase code to register) .

NOTE!!! If you are starting a new topic and have got problems with your site and you want us to check what`s wrong please always give url to your site because without that we can`t check what`s wrong. Each case may be different because of your installed plugins, servers or other things.

IMPORTANT!!! Along with your inquiry, please attach the address of the page which concerns the question. This will cause the time to answer on your question will be much shorter. If you do not want to publish your address publicly in the forum, please send a private message. Thanks!

Hide next previous from single product & Change number of products per row

edited March 22 in WooCommerce
How to hide next previous from single product.

And I need to show 2 columns for shop, but the betheme option have 3/4/masonry or list option only.

Added the following code in child theme's function.php, but nothing changed.

 * Change number or products per row to 2
if (!function_exists('loop_columns')) {
    function loop_columns() {
        return 2; // 2 products per row
add_filter('loop_shop_columns', 'loop_columns');

There are 4 columns and I need 2.

Please guide. Sorry if isn't related to theme but the docs said if it doen't change contact theme support as it might be hard coded or something.


  • Please sign in to see answear!
  • Hi, Thanks for your reply.

    1) I didn't found any option so I hide it with css.
    2) That's fine, I changed the page width from 1040px to 1240 px wide and the content looks fine now.

    I've another minor issue, I just installed SSL on my website.
    And changed the URLs in database from http to https (wp_post & wp_postmeta)

    But the muffin builder's WRAP > Background | Image. The image urls show http, and I don't know how to change them in DB. If I remove and add again it does fix the issue but manually doing so is tiring. any help on this plz...

    plz see images for reference

  • Please sign in to see answear!
  • edited March 24
    Dear Pablo Sir, you are awesome help. Really appreciate. Thanks for the plugin, will try.

    1) I think hiding content with css is just a hack. And it uses many extra queries in backend impacting performance as well. I would really appreciate if you could help this in code side.

    This is the css I used
    .woocommerce-content .post-nav, .fixed-nav-prev, .fixed-nav-next {
       display: none;

    Items which I need to remove.
    1) On Single-Product, The arrows and nex prev products are marked in red in THIS  pic
    2) In menu Cart Icon

    On my other site
    1) In menu search Icon
    2) The Fancy Heading having style set to arrow the text gets cut off. shouldn't it's size be responsive? Pic
  • Please sign in to see answear!
  • edited March 25
    Hi again.

    3) On home page, hare's the link
  • Please sign in to see answear!
  • Hi, so the font heading size didn't have any effect, because the fancy heading had its own styling.
    I had to override the responsive css for that manually. Many thanks for your time. cheers
  • Please sign in to see answear!
  • edited April 1
    Hi Pablo, So in the shop options I set "Related Products | Count" to 0. but it still shows them on page.
    Strange, This works fine in my other website.

    Also I got error for the plugin you gave to migrate site https:

    Deprecated: strpos (): Non-string needles will be interpreted as
    strings in the future. Use an
    explicit chr () call to preserve the current behavior in
    . php on line 39

    I've php 7.3 installed, nginx ubuntu 18.04

    EDIT: There was a type in fuction call line 39, fixed it.
    Most url seems to be working fine but Revolution slider images still shows incorrect url

    Also, I want to add google tag manager code right after body tag for all pages. is there any option for this in theme?
  • Please sign in to see answear!
  • sorry for late reply & appreciate your work.

    2)  the plugin you gave me didn't update slider urls from http to https. I checked the code of plugin and its not coded to work with revolution slider. Also the slider urls have escaped // like /\/\

    I'll ask if anything else needed, Thanks
  • Please sign in to see answear!
Sign In or Register to comment.