WMPL Custom language switchers doesn't work on BeTheme

Hello, I'm using Betheme (Clothing store theme) with a regular license of WPML. I want to customize the flag sizes and I've activated the "Custom language switchers" function under WPML but nothing happen.

The size and the style of the flags remain the same trying to change values and options. Is this a bug of compatibility between BeTheme and WPML? Let me know how I can solve this issue, thanks Massimo.


  • Hi,

    Please always attach a link to your website so we can check it out. If the page is offline(localhost), then our help will be limited. You will have to contact us when the page is online. Also, please make sure that the page is not under maintenance before you provide us with the link.

    It is always a good idea to also attach a screenshot showing your issue.


  • Hello, Phil the website is www.italianknitwear.it but is currently under consrtruction, we'll finish the work in the next two days but this issue should be solved before the site will be online, possibly...any suggestion to manage the problem?

    In the screenshot you can see that I've activated WPML Custom language switchers changing the flag size from the standard 18 x 12px to 32 x 26px. Looking at the second screenshot (but I don't think you can check well the problem), the flags still remain the same, no increased size is visible.

  • Please send us WordPress dashboard access privately thru the contact form, which is on the right side at http://themeforest.net/user/muffingroup#contact and we will check what might be the reason.


    Please attach a link to this forum discussion.

    Sending incorrect or incomplete data will result in a longer response time.

    Therefore, please make sure that the data you are sending are complete and correct.


  • Hello, I sent what you're requested through the form http://themeforest.net/user/muffingroup#contact

    I await your feedback, thanks

  • Please, use the following CSS code:

    #Top_bar .top_bar_right .wpml-languages img{
     width: 32px!important;
     height: 16px!important;

    Put it in Betheme -> Theme options -> Custom CSS & JS -> CSS. If the problem appears that the menu goes to the second row, please, check the following link:



  • Hello, thanks for the tip but I knew that I could correct through CSS this issue. I would like to know if there is a general bug between this WPML function, kind of control (Custom language switchers ) and BeTheme.

    I've added the CSS you wrote to the Custom CSS and everything is fine but please , just tell me if that WPML bug is related just to this particular theme, thanks.

  • There are pre-defined styles for language switcher hardcoded in our theme.

    The styles you set in the WPML refer to the language switcher added to the menu.

    Best regards

Sign In or Register to comment.