bedava hesaplar nulled scripts mod apk indir youtube mp3 dönüştürücü

Menu isn't functional on mobile devices

The menu is fine in full screen however, when an attempt is made with a smaller window the menu doesn't work. Also I noticed that the url has a # at the end as if it's setup as a dummy custom link option.  Thanks in advance.

Comments

  • Hi,

    the menu may not work because there is 500 Internal Server Error in your javascript logs what you can see on http://pasteboard.co/1VdskqhE.png and this should be fixed first before the menu will work.

    Thanks!
  • Is there a reason why the url is having a (#) on it when the actual page doesn't have that? It's almost like a custom link menu where you'd put the hashtag there so that you can have a button that doesn't go to a particular page
  • With this tag we usually replace default url. And if you don't like it, you can change it's link.
  • Do you think that's the reason why this is happening with the menu?  Considering that's not my homepage.. also where would i go to change that?  Because my Home Menu is a page and not a custom link.  I'm getting a push back from my hosting company that's saying this issue is theme related do you have a means of solidifying that it isnt theme side?  Thanks again.
  • Yes, we are sure that this is a problem. Just open your site in html mode in Firefox for example (CTRL+U) and see that your website is not loading all elements. Your code is cut suddenly and footer with javascript is not loading. And this happen because of server settings only.
  • So do you think it's a php parameter that's not working because i thought javascript is native to the site and not the server.
  • Yes, this is what we think. If site code is cut, it's usually server problem.
  • i'm having them look at this issue
    I have a question 
    why is it that when the site is resized the url goes from 
    www.highsadityhair.com
    to 
    www.highsadityhair.com/#     <---- where is the (#) coming from?  Also if it's going here I don't know where to set the menu for it in which may be causing the problem. The only time you use (#) on a menu button is when you want to have a menu display but not go anywhere.
  • The menu does not work because you got errors in javascript console what you can see on http://pasteboard.co/25WaS8Jy.png and because it's Internal Server Error you must contact with your hosting admin.
  • So  the java console is causing the url to show a (#)   this is what I've received from the hosting support in reagrds to the situation

    I have checked the website http://highsadityhair.com/ and was able to receive the error in the firebug console. However, there is an error generated from the website and the error log shows the following details: 

    20150720T020846: highsadityhair.com/index.php 
    PHP Parse error: syntax error, unexpected T_STRING, expecting ',' or ';' in /hermes/waloraweb092/b2912/as.boone1/public_html/wordpress/wp-content/themes/betheme/footer.php on line 94 

    The theme is corrupted and has a syntax error. This could be causing the error in the firebug tool also. Please check the script of the theme or use any other theme and then verify the functionality of the website. The error logs can be viewed at https://www.accountsupport.com/controlpanel/cgiManagement/cgiErrorLog.bml . If there is any issue, please update the support console. 
  • Sorry but we can't agree with you unfortunately. Did you checked your html code? If not, please take a look at http://pasteboard.co/2c0kvzWN.png and see how your code looks like. It's cut what means you did something wrong, one of your plugins is the reasons or server is not able to to load full content because of limits.
  • I haven't touched the code mainly for this reason because I don't want to have issues with it.  Is it possible to show how the code should look?  Also nobody has addressed why is it that the site url is called highsadityhair.com  but when you resize it and click the menu button the url switches to www.highsadityhair.com/# 

    I've also deactivated all plugins and I'm still having the issue.
  • Also on the footer.php which were pointed out by the hosting company do we have a syntax error?
  • If you did not touched anything, then problem is definitely related with one of the plugins or with limits on server side. Of course you can overwrite all theme files via FTP but if this won't help, then you must contact with your server administrator because we do not have other suggestions.

    About footer.php file, we do not see any error on site so we can't tell if there is something wrong or not.
  • Man this is turning into a disaster.  I'm not sure what to have them check is it the php settings or what have you.  I turned all the plugins off so I dont think it's that.  I'll see what they can do is it a certain parapemeters of PHP version necessary for the theme?
  • How can we know what exactly happened if there is no errors in console or in the code? If there is no errors on site side, only server admin can check it in the server logs. This is how how it works and there is no other way to find what is the reason of that problem. We already told you where the problem is and now your server admin should check it in logs.
  • edited July 2015
    I'm going to contact them on a live chat.. but why isn't this part being addressed I've asked like 3 times.

     when you resize it and click the menu button the url switches to www.highsadityhair.com/# 

    Is there a call made to a child or something that causes the menu url for example home shows a (#) at the end of the url
  • Hello can someone answer this question isn't this javascript related? 

    when you resize the window and click the menu button the url switches to www.highsadityhair.com/# 

    Is there a call made to a child or something that causes the menu url for example home shows a (#) at the end of the url
  • As we wrote several times, the problem is related with the code which is cut. And there is a reason why it is cut. Limits on server does not allow to load whole content properly and that's why javascript is missing and menu does not work.
  • I contacted the hosting company they said it is fixed could you determine the menu doesn't work still.  However now when i run it through the w3cvalidator it does work but when previously it wouldn't work due to a Server 500 error..   And in firefox when i do the Control U there's a comment this at the bottom


    Parse error: syntax error, unexpected T_STRING, expecting ',' or ';' in /hermes/waloraweb092/b2912/as.boone1/public_html/wordpress/wp-content/themes/betheme/footer.php on line 101


  • This message clearly says that footer.php file is corrupted. We recommend to overwrite current file on FTP with the one from package because someone tried to modify this file and probably had no idea how.
  • I never tried to modify that since i dont' know anything about php etc.  I just installed it on a clean install of wordpress.  However, are you able to see any server errors still?  I know initially there were one and when i ran validator previously I received it however I am not now.
  • No, we do not see any server errors on your site. But the site code is still cut the same as recently so your server admin did not fixed anything. Of course you can overwrite current file on FTP to check if this will help, but we guess this won't help you because the site is cut because of limits on server side. But of course please overwrite file to be sure.
  • Initially i was getting a 500 Error I think you all pointed that out in which was causing the javascript to not load.  When you're saying limits on the server side what limits are you referring to so that I can have them correct it.  Finally, which files should I overwrite?
  • Is it possible to use a different type of menu for mobile??
  • This could be everything but server admin should be able to see everything in console.
Sign In or Register to comment.
bedava hesaplar nulled scripts mod apk indir youtube mp3 dönüştürücü