Forum has been created to help all our customers in properly working our theme. We offer complete help with configuration theme and make default look, just like on our Tisson demo. We don`t offer theme customization.

Before creating a new discussion, please:
1. Check on forum if discussion hasn`t been created before. Use the forum Search on the right.
2. Read carefully the documentation included to package.
If you didn`t find what you need and would like to post a new question click the "Start a New Discussion" button on the right.
4. You can post on forum only after registration (you need purchase code to register) .


NOTE!!! If you are starting a new topic and have got problems with your site and you want us to check what`s wrong please always give url to your site because without that we can`t check what`s wrong. Each case may be different because of your installed plugins, servers or other things.

Size Content to Viewport Issue in Google PageSpeed Insights
  • Hello -  looking for some assistance please.

    Running Wordpress 4.1, Tisson V1.2.2, Revolution Slider V4.6.5 and all other plugins up to date. 

    When I run Google PageSpeed Insights I am given a "Should Fix" warning of:

    "Size content to viewport

    The page content is too wide for the viewport, forcing the user to scroll horizontally. Size the page content to the viewport to provide a better user experience.
    The page content is 1,200 CSS pixels wide, but the viewport is only 320 CSS pixels wide. The following elements fall outside the viewport:"
    I have not changed any coding settings and this is from a fresh install.
    I have selected responsive mode in the Tisson general settings. I was under the impression that this should make the whole site responsive and not have view port issues on any device?
    Can you please advise what I need to do to correct this? Google is saying: This page may not pass Google's Mobile-Friendly TestLearn more.- Which I know will damage rankings and also is not user friendly at all.
  • 5 Comments sorted by
  • Well it looks like I resolved the issue by editing the "headers.php" file in "/wp-content/themes/tisson" Folder.

    I removed this line: 
    <?php if( mfn_opts_get('responsive') ) echo '<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1">'; ?> 

    And added this one: 
    <meta name="viewport" content="width=device-width, initial-scale=1">

    This cleared the warning message and returned the responsiveness to mobile device.

    What makes this really bizarre is that I then changed the headers.php file back to its original state and the issue has not come back. I am leaving in this file in the original condition now with now fault. What the?

    Really strange issue here, not sure if anyone can explain this? But at least now the issue is resolved.
  • Hello,

    I posted this issue back in April 2015 and now I am having the same issue.

    This time my problem is when I have updated to Wordpress 4.3, Tisson 1.2.6 and Revslider 5.0.4.1. The upgrade went well however when I view the website on a mobile device the slider images are way too wide. 

    This can be shown by Google Page Speed Insights with the same error message as last time: 


    Should Fix:

    Size content to viewport

    The page content is too wide for the viewport, forcing the user to scroll horizontally. Size the page content to the viewport to provide a better user experience.


    I have tried the process I used last time (in the comments above), however this is not resolving the issue this time. Can you please look into this for me?

    My site it: www.ahcln.com.au

    Thanks,