Read-more tag in Blog is being ignored

I have the blog integrated on my home page. I added a read more tag in a post through the menu (code is <!--more-->) in Wordpress-Posts but it doesnt add a read more button to my post. Instead it shows the whole post without any formatting.

The read-more option is also turned on in muffin blog options of the home website.

What could be the problem here?

The website can be found at:


  • At this moment we don`t have this option included because to be honest nobody never didn`t asked about that. But we`ll definitely add it for you with next update.

    Thanks for understanding!
  • Hmm I am not sure whether you understood my question correctly. I want to add a read more button to my posts which is normal in many themes but the betheme seems to ignore the readmore tag.

    Is there really no option to have a read more button in blog posts?
  • edited June 2014
    We understand what you mean very well but as we wrote we do not support this tag because nobody never asked about it. We got "Read more" button but on blog page where is the whole list of posts what you can see on but this works a little bit different. We create excerpts for Blog page much modern method. Excerpt which shows on blog page like we showed above comes from "Excerpt" field which is available under "Post options" section while you create/edit post. If you don`t see this field in your wordpress it means you have turned it off and to turn it on you need to click on "Screen options" in right top corner, then check "Excerpt" field and after that you will see additional field at the bottom of created/editing post called "Excerpt". Since now what is in excerpt shows as excerpt on blog page but the whole rest show only on single post page. We hope this solution is what are you looking for.

    But as we wrote we can add 'read more tag' possibility with next update but will be great if you can tell us how this should exactly work. As far as we know this works exactly the same as we decribed above with "Excerpt" but in this case you have only one text in wordpress editor for post page and what is before 'read more tag' shows only as excerpt on blog page and on single post page shows everything (text before this tag and after). Are we right?

    Hope all will be clear. We really appreciate if you can reply on our question. Thanks!

    EDITED!!! We already realized that this tag works fine :) The problem you have probably is related with excerpt. If you have any content in "Excerpt" field for post that just excerpt will be showed instead of text before 'read more' tag. We tested it on our 2 different demos and all works as you need. So if something does not work on your website, then please send us access to your dashboard on pm and we`ll have a look on it.
  • I am having this problem in BeTheme as well and the excerpt field doesnt even show...
  • kpavlovsky
    It all depends on the blog style and if you are using an item for blog or the default blog page.

    The excerpt field
    this is the excerpt, please edit the field. TO do this, edit the page and find the excerpt field on the bottom of the page, if you do not see it, you will need to enable this in the screen options (top right corner of the page edit)

  • ok, I found the excerpt field. It is empty and yet the theme is still ignoring my more tag??
  • The more tag is not supported by us. The excerpt field will just show a fixed ammount of text which you can set in theme options. The read more button can be switched on by selecting other styles of blog in theme options>blog
  • Hi,
    you wrote 2014 that you want to:
    "At this moment we don`t have this option included because to be honest
    nobody never didn`t asked about that. But we`ll definitely add it for
    you with next update."
    when will it be possible to use the <!--more--> code ?
  • edited June 2020
    The <!--more--> option is not working for pagination, in the basic wordpress (without betheme) this option is just for selecting to which moment the excerpt field is displayed.

    If you want to have pagination on the posts, you have to use <!--nextpage--> in the gutenberg editor.
  • edited November 2020
    Here is codes for [Read More...]

Sign In or Register to comment.