bedava hesaplar nulled scripts mod apk indir youtube mp3 dönüştürücü

Add More Than 2 Custom Fonts?

Hey guys,

Loving the theme so far! I was wondering if there's a way to add more than 2 custom fonts?

Right now there's only space to add 2 custom fonts in: BeTheme Options > Fonts > Font Family

However, I'd like to add more?

Comments

  • Hey,

    at this moment it is possible to add only 2 custom fonts.

    Thanks!
  • So, make it possible, its urgent
  • I fount the solution  to  increase the custom form fields from 2 to  5
  • HI Zero how did you do it? 
    I need more fonts also!
    Please let me know
  • I would like to know that as well ;-) It must be possible to add more than only 2 custom fonts!

    Thank you!
  • I, too, would very much like to hear a solution/workaround. Any help would be appreciated Zero360Marketing 
  • did anyone figure out where to change the custom form fields?
  • Is there a solution?
  • No, we do not have such feature included yet.
  • edited December 2016
    I was able to change font by using some CSS.

    First you have to upload custom fonts to your server with FTP. Here's the link: 

    Adding Custom Fonts in Wordpress Using CSS3 font-face


    I needed to override font in columns. So what I did in Muffin Builder is:

    First create column by Add Section -> Add Wrap -> Add Item -> Column

    You would add some text inside of that column and you would wrap that whole text inside of <p></p> tags and inside of <span></span> tags with inline style.

    So it would look something like this:

    <p><span style="font-family: 'YourCustomFont';">Here would be your content for that column</span></p>

    You would replace 'YourCustomFont' with your custom font.

    Also make sure that 'YourCustomFont' has single quotes and is surrounded with font-family double quotes ""..... like line of code above  "font-family: 'YourCustomFont';"


    For Fancy Heading (for example) you would follow steps above but instead of Column you would choose Fancy Heading and inside of Fancy Heading settings, Title filed (at the top) you would add custom font to that title like this:

    <span style="font-family: 'YourCustomFont';">Your Title Here</span>

    Hope this can help some of you guys.

    If it does help, please let me us know here.

    Cheers!

  • still not available in 2018
  • You can add more custom fonts by editing the following files: 
    • fonts.php
    • theme-options.php
    in the theme-options.php duplicate the code under the comment line "font 2"
    replace all font 2 by font n (font 3 for example)

    in the fonts.php edit lines under the comment "custom uploaded fonts"
    example with 3 custom fonts:

    // custom uploaded font

    $font_custom = mfn_opts_get('font-custom');
    $font_custom2 = mfn_opts_get('font-custom2');
    $font_custom3 = mfn_opts_get('font-custom3');

    if( $font_custom || $font_custom2 ){
    $fonts['custom'] = array();

    if( $font_custom ){
    $fonts['custom'][] = '#'. $font_custom;
    }
    if( $font_custom2 ){
    $fonts['custom'][] = '#'. $font_custom2;
    }
    if( $font_custom3 ){
    $fonts['custom'][] = '#'. $font_custom3;
    }
    }
  • You have to add font in this file : 
    rtl.css
    muffin-options/fonts.php

    That's it.
  • I have followed Natchoin already and i can upload custom font 3. but the font does not work. i mean it does not change font.

    Please help!
  • Instead of customizing the theme files, you can add them through the @font-face rule https://www.w3schools.com/csSref/css3_pr_font-face_rule.asp
    and set it through the inline css.
    Thanks
  • edited February 2020
    Hi

    I have folder that contain 4 folder :  Eot , ttf , wof ,woff2 , and includes many
    fonts,

    I have the font face like this:

    @font-face {

                    font-family: myfonts;

                    font-style: normal;

                    font-weight: normal;

                    src: url('fonts/eot/myfonts.eot');

                    src: url('fonts/eot/myfonts .eot?#iefix')
    format('embedded-opentype'),  /* IE6-8 */

                                     url('fonts/woff2/myfonts.woff2')
    format('woff2'),  /* FF39+,Chrome36+,
    Opera24+*/

                                     url('fonts/woff/myfonts.woff')
    format('woff'),  /* FF3.6+, IE9, Chrome6+,
    Saf5.1+*/

                                     url('fonts/ttf/myfonts.ttf')
    format('truetype'); }

    I have add
    all that lines in “rtl.css” and also add the font name in muffin-options>fonts.php
    , see the example

    $fonts['system']
    = array(

                    // Add By me //

                                    ‘Myfonts1’,

                                    ' Myfonts2',

                                    ' Myfonts3',

                                    ' Myfonts4',

                                    ' Myfonts5',

                                    ' Myfonts6',

                       // Add By me //

     

    And all
    fonts load in the theme options> fonts> font family

    But the
    problem is fond dos not loaded.

    This is my font and css fils Please cheek
    that wat is the problem to preventing font load ?

    Thanks

     

     




    Natchoin The 3rd font dos not work in that scenario you said before.


  • The @font-face rule should be used in the Theme Options > Custom CSS & JS > CSS.
    If location of the font will be proper, you will have to use the "inline-css" with "font-family" parameter to change the font of some kind of text - it will not be displayed in the dropdowns where you select the font.
    Thanks
  • I tested and that is not work , Would you please show me how to do that ? maybe I'm going wrong way.
    Thanks
Sign In or Register to comment.
bedava hesaplar nulled scripts mod apk indir youtube mp3 dönüştürücü