Forum has been created to help all our customers in properly working our theme. We offer complete help with configuration theme and make default look, just like on our Be|theme demo. We don`t offer theme customization.


Before creating a new discussion, please:
1. Check on forum if discussion hasn`t been created before. Use the forum Search on the right.
2. Read carefully the documentation included to package.
3. If you didn`t find what you need and would like to post a new question click the "Start a New Discussion" button on the right.
4. You can post on forum only after registration (you need purchase code to register) .


NOTE!!! If you are starting a new topic and have got problems with your site and you want us to check what`s wrong please always give url to your site because without that we can`t check what`s wrong. Each case may be different because of your installed plugins, servers or other things.


IMPORTANT!!! Along with your inquiry, please attach the address of the page which concerns the question. This will cause the time to answer on your question will be much shorter. If you do not want to publish your address publicly in the forum, please send a private message. Thanks!

Display of Iframe on Page

I have a standalone page on same domain and want to display it in an Iframe from wordpress site via muffin builder.

I looked at some of the post feedback and answers you provide but unable to accomplish it.

What option or item I need to use to display it (that is an iframe correctly)?
What I got is this: https://www.screencast.com/t/MIblmhSRX4p  which is in this page www.questforlife.club/claculator/ -as you can see it shows full width but only part height.

I want to display this entire page of www.questforlife.club/en in that ifram e

Thanks

Comments

  • Please sign in to see answear!
  • Paste the iframe html? 
    It is already in there:

    <iframe id="myframe" src="https://www.questforlife.club/en" scrolling="no" marginwidth="0" marginheight="0" frameborder="0" vspace="0" hspace="0" style="overflow:visible; width:100%; height:100%; display:block"></iframe>

    I tried using a Content WP and Column block  to host the html iframe code but same behaviour. It does not show full height. Only partial 

    but same code in an external standalone page (not part of BeTheme wordpress) 
    https://www.questforlife.club/en/test.htm resolves ok
    <iframe id="myframe" src="https://www.questforlife.club/en/" style="position: absolute; width:100%; height: 100%; border: none;"></iframe>


    So I am wondering what in the Betheme that is preventing the iframe rendering correctly.
  • Please sign in to see answear!
  • edited September 15
    Hi, I have a very similar problem, but I am trying to display a page in Wordpress in BeTheme using a script. And that script has an iframe inside. The iframe has indeed width:100%;height:100%.

    The thing is that everything works perfectly on other templates, so I don't understand why it is height:100% doesn't work at BeTheme. 

    I added the same script to 2 different pages just to check if it works:  
    http://connectinginternationalmedia.com/test1 - using Template from Argent (Automatic) - and it works perfectly 
    http://cleverbiken.de/sample-page - using BeTheme - doesn't work.

    If I extract the iframe from the script and set the height to px then it is displayed indeed, but all other functions of the script don't function. The script is external and I don't want to try to change it in any way. 
    Is there any solution? 
  • Please sign in to see answear!
  • edited September 20
    That's what I said - it doesn't work. Yes, I checked plugins and cache, but unfortunately, it doesn't help. 

    I guess the comment of Bryan has something to do with the problem. I've tested it setting px into iframe and it works fine. The problem is that I can't keep the extracted iframe and should post a script with the iframe inside, and then I can't change the iframe. 

    So is there any solution on your side? And again, why does it work with other templates? ;)

    Thanks! 
    Viktoria

  • Please sign in to see answear!
  • Ok, thanks, it looks better. But mobile safari mobile devices don't support vh. 
  • Please sign in to see answear!
Sign In or Register to comment.