help? an error I get after most recent update (6.4)

I updated my site to the most recent version of the theme, and now whenever I am trying to remove an item from my shop's cart, I get this error:

: Cannot modify header information - headers already sent
by (output started at
in /home/content/p3pnexwpnas03_data02/17/2302717/html/wp-includes/pluggable.php on line 1178

The weird thing is -
there is no line #43 in betheme-child/functions.php...

Also - when I click the "add to car" button, the cart is not updated without refreshing the page and the check out button is gone!!!


  • Hi,

    as we see, in header on main page you have error related with plugins. Please at first deactivate all plugins and addons and then check if it works.
  • how can you see the header please?

  • also, I am trying to update my woocommerce plugin and it is updated. However, it is version 2.2.11
    so I went to the woocommerce website, and this is actually their last stable version. They don't have 2.3 anywhere :(
    What am I missing?

  • ok I just found it: apparently woocommerce 2.3 has some frontend changes but it is still at beta.

    So now my question is - how do I go back to Be previous version...?

    I am so sorry for this whole mess.....
  • We already checked older WooCommerce version (2.2.11) with latest theme version and of course everything works fine. We are sure the problem is not related with theme but with something else (wordpress installations, plugins, etc). Now, when we visit your website all we see is below message:

    Fatal error: Cannot call overloaded function for non-object in /home/content/p3pnexwpnas03_data02/17/2302717/html/wp-includes/user.php on line 328

    And this error is not related with theme at all. Just switch to default wp theme and you will get the same error.
  • ok now I am really confused :-(
    I don't see this error you mentioned...
    I deleted the new theme and installed a previous version. Also, I am now suing the theme itself and not the child theme like I did before.

    So how can I see the errors you are seeing? Are you looking at something specific?
    Thank you!!
  • We see it just when we open website
  • I think i am loosing my mind...
    I cleared all cache and cookies, I tried 4 different browsers in 2 different computers and I don't get the error you see :-(

    I am starting to think that it has to do with my ssl protocol.
    Do you think this is possible?
  • This could be the problem of course. We just showed you what we see so you can know. And we also checked on few different computers to be sure.
  • Ok I will try to figure what is going on with the system guy from my hosting.
    Thank you so much for your quick responses!
Sign In or Register to comment.