Forum has been created to help all our customers in properly working our theme. We offer complete help with configuration theme and make default look, just like on our Be|theme demo. We don`t offer theme customization.

Before creating a new discussion, please:
1. Check on forum if discussion hasn`t been created before. Use the forum Search on the right.
2. Read carefully the documentation included to package.
3. If you didn`t find what you need and would like to post a new question click the "Start a New Discussion" button on the right.
4. You can post on forum only after registration (you need purchase code to register) .

NOTE!!! If you are starting a new topic and have got problems with your site and you want us to check what`s wrong please always give url to your site because without that we can`t check what`s wrong. Each case may be different because of your installed plugins, servers or other things.

IMPORTANT!!! Along with your inquiry, please attach the address of the page which concerns the question. This will cause the time to answer on your question will be much shorter. If you do not want to publish your address publicly in the forum, please send a private message. Thanks!

The following is missing: author. The following is missing: updated.

Hello MuffinGroup.

I am very happy with BeTheme. Now I have a question, which I could not answer with Google and your forum.

Recently I have a problem. My Google Search Console throws this error on most of my pages:
  • The following is missing: author.
  • The following is missing: updated.

Here is a picture:

I searched for these entries in page.php, single.php
  • <? php the_author (); ?>
  • <? php the_date (); ?>

I have not found both entries.

Many have solved the problem by changing these 2 lines to these:
  • <span class = "vcardauthor"> <span class = "fn"> <? php the_author (); ?> </ span> </ span>
  • <span class = "updated"> <? php the_modified_date (); ?> </ span>

Can I solve this with you? I've really searched everywhere, and can't solve the problem. Many thanks for your help.

My website:


  • Please sign in to see answear!
  • edited October 2017

    Of course I do not want to change anything. What I suggested above was just a call for help because I am dubious.

    My Webhoster says:
    This is a problem with the BETHEME theme.

    Yoast Pro says:
    Are you getting the missing hCard "author" or similar hEntry / microformat error in Google's structured data testing tool (live results) or in Google SearchConsole (cached results)? This is an issue with your theme, not with any of our plugins.

    Do I need to buy a support from you to solve this problem?
    I'm ready for that.

    Because of this problem I get a bad rank at google. The problem can only be due to BETHEME, because I have not changed anything.

    I've already found these topics from you, where others had the same problem:

    Here you say that the problem is already fixed, why I have that then?:

    Do I need to activate any function? Is something going away? As I said, I do not want to change the files, I am only looking for a solution to display in hEntry the author and updated.

    Please give me some advice, I would be so grateful to you ..

    Best regards

  • edited October 2017
    After hours search, I think I solved the problem.

    For people who have a hEntry problem, This is how I proceeded:

    Dashboard > BeTheme> Theme Options> Blog, Portfolio & Shop >

    There I have, "Post Metadata" 2 checkboxes set under AUTOR and DATE

    Here is a screenshot:

    In Google Test Tool for Structured Data, updated and author is now displayed. Now I'm waiting for Google to recognize the two hEntry entries in the Google Search Console (Webmaster Tools). Then I give you feedback. Perhaps that solves the problem.

    Support, perhaps you could answer me now this question, since the problem from above probably no longer exists:

    In my articles, this sentence is in the upper left corner
    Published by DECENTRALBOX at February 16, 2017 (Example:

    Can I display this instead of the top left, below, after the article?
    If it does not go under the article, would it work in the middle?

    I hid it meanwhile with this code:
    .post-meta .author-date { display: none; }

    Best Regards

  • Hello

    Is there no answer from you?

    Is something missing, a license or something? Where can I buy this for the support?

    Best Regards
  • Please sign in to see answear!
  • Hey AltcoinTrader,

    thank you for submitting the way it worked.

    I had the same problem with google search console, made the changes you did and in live-test it directly was shown as no more problem.

    Thanks a lot !
Sign In or Register to comment.