Forum has been created to help all our customers in properly working our theme. We offer complete help with configuration theme and make default look, just like on our Be|theme demo. We don`t offer theme customization.

Before creating a new discussion, please:
1. Check on forum if discussion hasn`t been created before. Use the forum Search on the right.
2. Read carefully the documentation included to package.
3. If you didn`t find what you need and would like to post a new question click the "Start a New Discussion" button on the right.
4. You can post on forum only after registration (you need purchase code to register) .

NOTE!!! If you are starting a new topic and have got problems with your site and you want us to check what`s wrong please always give url to your site because without that we can`t check what`s wrong. Each case may be different because of your installed plugins, servers or other things.

IMPORTANT!!! Along with your inquiry, please attach the address of the page which concerns the question. This will cause the time to answer on your question will be much shorter. If you do not want to publish your address publicly in the forum, please send a private message. Thanks!

Error 404 on Page Update

I have been working this problem for over 3 hours and am still getting this error.  This is my up-teenth Betheme install, and never have I seen something this persistent.  Please advise if this is a theme issue.

Here is how we built the site:
(1) Imported BeResume.  The site is only 2 pages, with a very long home page.
(2) Using muffin builder

This is what I've done to fix try to the problem:
(a) there is a phpinfo.php file on the site now, feel free to look at it.
(1) deactivated all 3 plugins
(2) switched to Twenty Seventeen
(neither of that worked, still 404 on home page update)
(3) Added .user.ini to site's root (Using Godaddy shared, this is preferred over php.ini)
Successfully increased Memory and max Vars:
max_input_vars: 5000
memory_limit: 512M
(4) Deleted .htaccess  via FTP.  Changed permalinks to something else.  Changed it back.
(These two things alone have always fixed this particular problem.)
(5) Uploaded fresh Wordpress files for version 4.9.1
(none of this has worked)
(6) Sat on phone with GoDaddy for 1.5 hours.  They updated the site to php 7.1 (or some 7x version)
(7) Since I'm on shared hosting, cannot change Security Mod (as suggested by many blog posts)
(8) Recreated the page from scratch by creating a whole new page.  I hit save every so often but got the 404 about 1/2 down the page.

Another of your suggestions was to reset the database since we imported a template. I'm concerned about doing this because I do not want to lose my work.

Please advise as I'm beyond frustrated and don't know what else to do.


  • edited January 13
    It's been 14 hours, and still have not heard back from BeTheme on this issue.  

    == RESOLVED==
    Here is how I resolved the issue.  
    Since this is a small website, I bit the bullet to try resetting the database since we did import a Betheme template.  (we'll show caution against importing in the future, since this is a risk we cannot take, and apparently a known bug to BeTheme).

    1 hour to completely manually document the website with lots of screen captures.  Saved /wp-content/uploads folder (just in case, it wasn't needed).
    * Installed plugin: Advanced WordPress Reset by Younes JFR.
    This is a quick reset and leaves only the admin's user/pass.

    45 minutes to re-create
    * Manually re-coded (via copy/paste from my documentation in Notepad) BeTheme Settings (including license info), CSS/JS, Menu, contact form, posts, pages (in that order, as the post-id's were needed on the pages)

    Hopefully this saves somebody out there countless hours with the same issue!  I use BeTheme on dozens of websites, and this is the first time I've run into this particular issue.  Show caution on importing an existing theme.  Otherwise, solid theme (with so-so support).

    Long story short - THIS WAS A THEME ISSUE.

  • edited January 15
    Please sign in to see answear!
  • hi ljcallander 

    I am sort of having the same issue as well. do you mean that if we don't import the template, we will be fine? that is working from bare ?

  • Correct, that is my recommendation.  If you have this issue, you will need to reset your database and start over from scratch.
  • Muffin - because it was the database that was corrupted upon importing a pre-built theme.
Sign In or Register to comment.