Forum has been created to help all our customers in properly working our theme. We offer complete help with configuration theme and make default look, just like on our Be|theme demo. We don`t offer theme customization.

Before creating a new discussion, please:
1. Check on forum if discussion hasn`t been created before. Use the forum Search on the right.
2. Read carefully the documentation included to package.
3. If you didn`t find what you need and would like to post a new question click the "Start a New Discussion" button on the right.
4. You can post on forum only after registration (you need purchase code to register) .

NOTE!!! If you are starting a new topic and have got problems with your site and you want us to check what`s wrong please always give url to your site because without that we can`t check what`s wrong. Each case may be different because of your installed plugins, servers or other things.

IMPORTANT!!! Along with your inquiry, please attach the address of the page which concerns the question. This will cause the time to answer on your question will be much shorter. If you do not want to publish your address publicly in the forum, please send a private message. Thanks!

Header and menu transparent on home page

Is it possible somehow to set two options from muffin options (transparent header and transparent top bar with menu) only on the home page? Link: I noticed that the body has two additional classes when set to transparent: "tr-header tr-menu".

If not, it could even stay transparent for the whole page, but when I set to transparent, my header gets bigger on all the pages. I set it to minimalist and would like to keep it this way.

So, I can achive my goal in two ways:

1. Set transparency only on homepage
2. Make header minimalist on subpages with transparency on


  • edited July 2018
    Please sign in to see answear!
  • Unfortunately, it doesn't work. As You can see on:, the slide on home page doesn't fit one page. When I set transparent header and transparent top bar with menu in muffin options, it fits perfectly (the progress bar on the botton is at the very bottom of the screen when scrolled up to the max)
  • edited July 2018
    Please sign in to see answear!
  • Please sign in to see answear!
  • I have to come back to this problem. The answer from the 9.July doesn't work in my case. You suggested the following css:

    #Header #Top_bar{
    background:transparent !important;
    box-shadow:0px 0px 0px !important;

    I checked and it works in some header layouts, but not in "Classic". With this css, classic header layout and all the transparency options turned OFF in muffin menu - i get header in a color set in header colors in muffin menu. And a transparent sticky menu. That's exactly opossite to what I would like to get. I need transparent header on home page (but non-transparent sticky). And non-transparent on all other pages. When I change to (for example) fixed layout: header is fully transparent.

    I managed to get more or less what I need (example: by using following options:

    - minimalist header ON
    - transparent header OFF
    - transparent top bar with menu ON
    - custom CSS:

    #Top_bar {
       opacity:1 !important;

    body.main #Header #Top_bar{
       background:transparent !important;
       box-shadow:0px 0px 0px !important;

    But one thing is still wrong. And it applies to standard betheme, without an costom css. Whenever you set transparent top bar with menu ON, the minimalist header doesn't work! Why is that? What's the connection between transparency and size of the header? I need the minimalist header, so please help me in one of two ways:

    either 1) fix custom css to make header (but not sticky) transparent in classic layout. Then I would be able to turn off top bar transparency and minimalist header should work again
    or 2) provide custom css to fix the minimalist header

    Here is how the header looks like currently (very high):
    Here is how it should look like (after turning top bar and menu transparency OFF):

    It the top bar and transparency is not possible with minimalist header (but why?), it should be declared in this option description. There is only one note now: "Does not work with Header Below. Header Creative requires background image uploaded above."
  • Please sign in to see answear!
  • it works, thank You. I really would like minimalist header independent from transparency options. Please, think about it.
Sign In or Register to comment.