Forum has been created to help all our customers in properly working our theme. We offer complete help with configuration theme and make default look, just like on our Be|theme demo. We don`t offer theme customization.


Before creating a new discussion, please:
1. Check on forum if discussion hasn`t been created before. Use the forum Search on the right.
2. Read carefully the documentation included to package.
3. If you didn`t find what you need and would like to post a new question click the "Start a New Discussion" button on the right.
4. You can post on forum only after registration (you need purchase code to register) .


NOTE!!! If you are starting a new topic and have got problems with your site and you want us to check what`s wrong please always give url to your site because without that we can`t check what`s wrong. Each case may be different because of your installed plugins, servers or other things.


IMPORTANT!!! Along with your inquiry, please attach the address of the page which concerns the question. This will cause the time to answer on your question will be much shorter. If you do not want to publish your address publicly in the forum, please send a private message. Thanks!

Layer Slider, Slider Revolutions, bakery page builder not installing

Hi, in Be theme > install plugins
it is not installing these three plugins
"Layer Slider, Slider Revolutions, bakery page builder"
ive asked host "SiteGround" and here is there reply
"I've accessed the "BeTheme" plugin installation page and then tried installing the "Layer Slider" plugin again and was able to recreate the issue. What I noticed is that the plugin is being downloaded from a remote repository instead of WordPress's plugin repository:
Downloading installation package from https://api.muffingroup.com/plugins/download.php?code=9f30fbd

This is why to verify whether the problem is caused by our server I then checked, from within your hosting account, if a connection to the remote repository is possible:

However as you can see from the extract above, I was able to successfully check the IP Address of the remote repository and perform a ping check. 

This leads me to believe that the problem is coming from the theme itself instead of the cURL request that's being sent. In this case I'd highly recommend contacting your theme's developers for further assistance on the matter. Note that the scope of our support does not cover assistance with third-party software such as plugins and themes so we can not further debug the issue. Still, we'll be happy to assist with any recommendations or solutions the developers may provide. 

guide what to do? siteground is quit popular hosting server and i dont think there shoudl be any problem at there end as ive installed multiple wordpress themes there.

THis is link of our website

Comments

  • Please sign in to see answear!
  • ive shared details there but email cannot be changed. i want you to share reply on my email id and cc it to [email protected] as we are handling the development
  • Please sign in to see answear!
  • edited August 11
    Bryan we are trapped between the two. Site ground is one of the most reliable wordpress hosting services. They've mentioned  the ping is working here
    "However as you can see from the extract above, I was able to successfully check the IP Address of the remote repository and perform a ping check. "

    what do you suggest we do if it is a timeout problem? cant you just provide us the plugons copy that we can use? precious time is being wasted.

    thanks.


  • edited August 11
    the site ground hosting says they have increased the timeout to 300 seconds and it still does not installs. the only option left is if we can install it via ftp. please provide.

    i also have to build another website with your theme. but will not be able to buy if that is not the case. please inform asap
    Please note you will be facing the same problem with all the clients who have hosting at siteground, or have timeouts less than 300 seconds
  • edited August 12
    Please sign in to see answear!
  • Why cant you just share the plugins so we can upload it via ftp and get out of this misery?
  • servers reply:

    We haven't been able to find any issue or a log for such on the server, which points to an issue with the server services and the SSL certificate.

    I noticed that your website is having a maintenance mode enabled and I will recommend you to deactivate it and try installing either of the plugins.

    However, as mentioned, based on the information so far, we believe it is related to the configuration of the theme of the website, not the server hosting services.

    Best regards,

    Marin Petkov
    Technical Support Team
  • Please sign in to see answear!
  • edited August 14
    Hosting reply:
    I have reviewed the case and would like to start with the fact that your website is fully covered by a valid SSL certificate and there are no parts of the website that load insecurely, due to the enforced HTTPS connection.

    You can verify this from here:

    https://www.whynopadlock.com/results/57d7cd2e-2059-470d-92f4-84a44658a9b2

    I also tried to install the recommended by BeTheme plugins - in bulk and one by one. The attempts resulted in various cURL errors that does not seem to be server side related, but most likely there are connectivity issues with the external repository from where the plugins are supposed to be downloaded.

    Additionally, I tested the connection towards one of the plugin's repositories and it is successful:

    curl -v https://api.muffingroup.com/plugins/download.php?code=9f3
    * Trying 149.202.6.209...
    * TCP_NODELAY set
    * Connected to api.muffingroup.com (149.202.6.209) port 443 (#0)
    * ALPN, offering h2
    * ALPN, offering http/1.1
    * successfully set certificate verify locations:
    * CAfile: /etc/pki/tls/certs/ca-bundle.crt
    CApath: none
    * TLSv1.3 (OUT), TLS handshake, Client hello (1):
    * TLSv1.3 (IN), TLS handshake, Server hello (2):
    * TLSv1.2 (IN), TLS handshake, Certificate (11):
    * TLSv1.2 (IN), TLS handshake, Server key exchange (12):
    * TLSv1.2 (IN), TLS handshake, Server finished (14):
    * TLSv1.2 (OUT), TLS handshake, Client key exchange (16):
    * TLSv1.2 (OUT), TLS change cipher, Change cipher spec (1):
    * TLSv1.2 (OUT), TLS handshake, Finished (20):
    * TLSv1.2 (IN), TLS handshake, Finished (20):
    * SSL connection using TLSv1.2 / ECDHE-RSA-AES128-GCM-SHA256
    * ALPN, server did not agree to a protocol
    * Server certificate:
    * subject: CN=muffingroup.com
    * start date: Jul 22 21:13:53 2019 GMT
    * expire date: Oct 20 21:13:53 2019 GMT
    * subjectAltName: host "api.muffingroup.com" matched cert's "api.muffingroup.com"
    * issuer: C=US; O=Let's Encrypt; CN=Let's Encrypt Authority X3
    * SSL certificate verify ok.
    > GET /plugins/download.php?code=9f30fbad-3f59-47c1-8ff3-33bd5fe7eea9 HTTP/1.1
    > Host: api.muffingroup.com
    > User-Agent: curl/7.61.1
    > Accept: */*
    >
    < HTTP/1.1 200 OK
    < Date: Tue, 13 Aug 2019 07:18:15 GMT
    < Server: Apache
    < Vary: User-Agent
    < Content-Length: 0
    < Content-Type: text/html; charset=UTF-8
    <
    * Connection #0 to host api.muffingroup.com left intact


    However, when I attempt to download the resource I am unable to do so.

    My recommendation would be to ask the theme vendor to provide you with the plugin archives or an alternative location from where they can be downloaded and we would gladly try to install them for you.
  • Please sign in to see answear!
  • is there anything specific you want me to tell to hosting providers "siteground" that will help them understand the issue?
  • Please sign in to see answear!
  • unfortunately i cannot change hosting as it is provided by client and they fail to understand the issue as their other 3 WordPress websites work fine on siteground server.
    your theme is the only one having this issue.
    So if you can give a specific reason that would help 
    saying it is always hosting configuration issue is not helping.
    I would request you to try to update theme, it gives following errors
    "Download failed. cURL error 56: OpenSSL SSL_read: SSL_ERROR_SYSCALL, errno 104"
    "Warning: mysqli_query(): MySQL server has gone away in /home/customer/www/teacher-awards.com/public_html/wp-includes/wp-db.php on line 2007"

    does this help identifying the issue?
  • Please sign in to see answear!
Sign In or Register to comment.