Forum has been created to help all our customers in properly working our theme. We offer complete help with configuration theme and make default look, just like on our Be|theme demo. We don`t offer theme customization.

Before creating a new discussion, please:
1. Check on forum if discussion hasn`t been created before. Use the forum Search on the right.
2. Read carefully the documentation included to package.
3. If you didn`t find what you need and would like to post a new question click the "Start a New Discussion" button on the right.
4. You can post on forum only after registration (you need purchase code to register) .

NOTE!!! If you are starting a new topic and have got problems with your site and you want us to check what`s wrong please always give url to your site because without that we can`t check what`s wrong. Each case may be different because of your installed plugins, servers or other things.

IMPORTANT!!! Along with your inquiry, please attach the address of the page which concerns the question. This will cause the time to answer on your question will be much shorter. If you do not want to publish your address publicly in the forum, please send a private message. Thanks!


edited April 2015 in Theme support
Hello Guys,

All my icons are gone, the icons that are shown on my website are chinese?
even when i update the theme they still dont appear,



  • Please sign in to see answear!
  • edited April 2015
    hey muffingroup,

    thanks for answering the question,
    after some google research i had to add this to my .htaccess file to make it work thanks !
    <IfModule mod_headers.c>
    Header set Access-Control-Allow-Origin "*"
  • Please sign in to see answear!
  • Works! Thanks :)
  • Worked for me, too. Thank you :)
  • edited June 2016
    This hasn't worked for me. I tried inputting this  Header set Access-Control-Allow-Origin "*" just below <IfModule mod_headers.c> before the rest of the code and it didn't work. Even tried 
    Header add Access-Control-Allow-Origin "*"
    Header add Access-Control-Allow-Methods: "GET,POST,OPTIONS,DELETE,PUT"
    Header add Access-Control-Allow-Headers: "Content-Type" and it still didn't work.

    Update: I contacted my host service provider and they made me aware that I cannot have the Cors
    library enabled as my server is a shared one and therefore I do not have root access and won't
    do unless I update my simple folio website to have the capabilities of a VPS at the cost of 30
    pounds a month sooo Is there any other way to get rid of the boxes and Chinese characters?
  • Please sign in to see answear!
  • @muffingroup I contacted them and they said there's nothing they can do. Got any other ideas of what I can do, as this affects the website on mobile too as the menu icon doesn't show. How can I replace this? 

  • Please sign in to see answear!
  • I'm having the same issue as @drewcastro. Rather than say it's an issue to be addressed with the host, can't you please provide a way to remove the icons? Even pointing us to the appropriate file to edit them out ourselves would be helpful.

  • Please sign in to see answear!
  • Hi

    I am also having this issue. I have added a duplicated demo site onto another server to see if this fixes the issue but both demo sites now show chinese characters. I contact both hosting companies and they say there is nothing they can do and say its a htaccess thing.

    Every code I add to the htaccess file doesn't work and it appears that there are other customers who also face this so is there any advice you can give because this not only affects the social media icons but also the buttons on the site as well
  • Please sign in to see answear!
  • Hi

    You can see the social icons are now square I removed telephone and email icons on the top bar they were both chinese symbols

    This is a third server that I copied the site to just to test and the icons are fine
  • Please sign in to see answear!
  • I haven't got an extra FONTELLO plugin installed?
  • I have just checked again I have 100% not installed FONTELLO plugin

    Is it in the theme?
  • Please sign in to see answear!
  • Ah yes just spotted that

    Thank you and sorry for wasting your time on this
  • Works for me, thanks!
  • The .htaccess solution worked for me too:

    <IfModule mod_headers.c>
    Header set Access-Control-Allow-Origin "*"
  • Hi team, looking for a little help as I have the same problem after upgrading my site from HTTP to HTTPS.

    My CDN (AWS Cloudfront) is serving all the other static content perfectly, except for the font file. The icons are not displayed.

    I've tried adding / editing / deleting the Access-Control-Allow-Origin entry from .htaccess but it hasn't made any difference.

    I have two Wordpress installations, one for the main site and another for the blog. The links are pasted below.
    Main site:

    Can you please have a look at my site and let me know what may be causing it? I'd appreciate your inputs.
  • Please sign in to see answear!
  • Hi! I have the same issue on my site

    In Blog when the article is opened, the icon next to "Read more" button is not showing up.

     <i class="icon-layout"></i>

    If I have any conflicting plugin, please let me know. 

  • Please sign in to see answear!
  • For the benefit of other Betheme users who're using CDN, and facing an issue similar to mine, here's an update.

    The issue was that after I had implemented the .htaccess solution, the icon problem went away for some site visitors but not for everyone.

    I tried clearing the browser cache but it didn't help. I asked several other regular site visitors to clear their cache and recheck. But that didn't help either.

    I checked with the CDN team. After analyzing it, they said it could be because repeat visitors to the site were passing the old (http) URL in Access-Control-Allow-Origin. And the CDN server was trying to serve them old HTTP content which was conflicting with the HTTPS setting.

    New (first-time) visitors did not have this issue, since their Access-Control-Allow-Origin had the new .htaccess value. The CDN server was able to serve them HTTPS content along with the icon file without any conflict.

    Ignoring the underlying technical complexities (which I don't full understand either), the solution to the issue was quite simple.

    Invalidate the distribution on the CDN server.

    That fixed it for me! Some other site visitors who tested it had to clear their browser cache for the effect to be visible.

    So, if you are using AWS Cloudfront and tried all the right things, and you're still pulling your hair out, try invalidating the CDN content so it can start afresh.

  • Anyone with dream host? I've added the code they suggest and tried the one you guys suggested in the .htaccess but it hasn't worked.
Sign In or Register to comment.