bedava hesaplar nulled scripts mod apk indir youtube mp3 dönüştürücü

Page content showing up in menu navigation

For some reason the pages content is showing up in the navbar when I add the page to the menu/navbar.

image
«1

Comments

  • We guess you did something wrong in the code or maybe you modified core theme files and that`s why it happened but without url to your website we won`t be able to check it.
  • I changed no code at all. 

    here is the website http://162.144.97.111/~aiescom/
  • I took the pages out of the menu because they were making he website look broken. 

    Basically I think the issue was that the content was showing up in nav because it was in the wordpress editor. I copied that content and deleted it from the WP editor and moved it to the muffin editor and pasted content in visual composer add on.

    That still didnt work. Content still showing in nav.
  • Ahhh just got it to work.

    What I wrote above is the solution just incase someone else has this issue.
  • I've tried that on several pages and every time I add them to the menu (top or child level) the content still shows.
  • i have the same issue...even after moving contents to muffin editor....

    either way this is a bug...it is annoying that i have to create custom links for every menu item...please fix it ASAP.... some times all i have is basic content and i dont want to create things using muffin editor...i just wanna simply paste my content and move on to the next...

    need a solution and need it fast

  • Possum,

    Thanks for the tip.  I added a custom link to the menu and you were right, it did work.  At least I have a work around for the short term until Muffin Group can fix it.
  • Guys, please take a look on this topic http://forum.muffingroup.com/betheme/discussion/527/full-page-content-in-menu-item#latest where we explained what could be the problem and what should be done to remove it (this is menu item description).
  • edited August 2014
    Muffingroup, please stop linking to that as a fix, it's not a fix. I've tried the "workaround" you proposed (screen options, description, etc...), that does not fix it. In fact if I delete the page content in an effort to make it vanish from the menu, in my case that doesn't do anything either. For me it's permanently stuck in the database somewhere now. I've wasted 3 hours on this bug today, and was very happy with this theme until now. 

    Something in your latest update is not working, it's not a coincidence that we are all seeing this now. I encourage you to take another of your sites, create 3 basic pages, enter some text content in the wordpress "text" field for a given page, and then create your main menu. You'll see what we see (text from pages showing up in menu headers), it's not hard to reproduce. And I agree with possummultimedia , this is a fairly significant bug. 
  • edited August 2014
    I can confirm that the only workarounds to make the extra page content text disappear from the menu are:

    1) Create a custom link for your menu item, which is a short term workaround at best, but not a fix

    2) Use widget content from the muffin editor, which only allows you to pick from the muffin editor selections. 

    3) Sounds like someone bought the $25 visual composer as a workaround too, but that's obviously not a solution.

    We essentially can no longer simply type text in the wordpress text field, which is most of the point of wordpress in the first place. If it makes debugging easier, I bought this yesterday. I wonder when the others did, but I suspect we are all new users on a new version.
  • I am happy that my workaround helped others.

    As I said earlier this is a bug and needs to be fixed. please fix it and launch an update.

    As raphael said entering content in the text editor is one of the base features of the wordpress and i dont understand how could the content values taken automatically into description ( this is not a base feature in wordpress )

    i have been using wordpress for long time. I am also following your themes. I like this version of your theme and finally made a purchase when i was convinced that it is fully packed and worth spending money.

    and you guys need to update the documentation as well..it is still the first edition i guess as most of additional features and updated features and options are not listed. also not a easy to use documentation.

  • Guys,

    please be patient because this will be checked today and if you're right, this will be fixed of course so you don`t need to worry about that. But please give us a time because we got seriously tons of questions and we need to answer on all of them.

    Thanks for understanding!
  • No problem, we will wait. But just to frame this in context, this sort of bug on any wordpress template is probably second only to security issues, in terms of priority. People asking configuration questions should probably be put on hold while a show-stopper bug like this is ironed out. 

    Also to help you with your debugging if need be:

    wordpress version: 3.9.1
    browser: chrome Version 36.0.1985.125


  • Thanks for getting back to us.  It is without a doubt something not configured/working properly with the latest version of the theme.  I will add that another site I was working on with this theme did not have the issue from simply applying the updated theme.  I did not however add any new pages to the menu on that site to test.
  • edited August 2014
    Hi guys again,

    yesterday we`ve been checking what you wrote and you are definitely right (we have no idea why this happen and at this moment it is not clear for us because with this one thing wordpress is playing tricks definitely and the only possibly way to fix it now we`ll describe below but of course this will be fixed in next update as we promised above).

    In functions/theme-mega-menu.php file, please find line which looks like below:
    $description =  trim($item->description) ? '<span class="description">'. $item->description .'</span>' : false;
    and please replace it with below line:
    $description = '';
    We really sorry for this bug and hope you will forgive us ;) And this bug will be definitely fixed soon (hope next week at latest).
  • I don't even find the file on the functions folder of the theme. How is that possible?
  • @skiclass Sorry! The right file is functions/theme-mega-menu.php
  • @skiclass it is there and the line to edit should be 416
  • thanks

    please look into the request i made for future suggestion on adding new page type

    cheers

  • I had this issue (I created this topic) and the solution I found was very simple.

    Instead of entering wordpress content in the wordpress editor (that's what shows up in nav) just copy and paste that content in a "visual editor" box that you can add in the muffin builder (see below). Make sure to delete the original content in the wordpress editor after you paste.

    (this might take a few minutes to work so have some patience).

    image
  • @maxrevz Your explanation is fine of course but this should be definitely fixed because content from wordpress editor shouldn`t be showed in menu items. This bug is on our side and must be definitely fixed soon. But of course thanks for your explanation ;) Maybe this will help some other users.
  • Thanks muffingroup, the code replacement you recommended worked just fine. Quality workaround, thanks again.
  • Oh Geeze! I'm glad that this topic was here as after a full day of work my entire mega-menu disappeared and my site had content from one page transposed over another page. The fix noted above worked, thanks so much for addressing this right away. Also tanks for all the other suggestions from the other members. Nice job!!!!
  • @muffingroup

    Just as an FYI...  with the 3.6 release of the theme update the menu item was not corrected.
  • @CicorMarketing We know that. This will be fixed with 3.7 version which will be ready this week because we need to make a little bit different so it will be more compatible with other stuff.
  • @muffingroup No worries, the fix still works for the menu as it is right now.  Just wanted to make sure you were aware.
  • @CicorMarketing - thank you so much. This helped me, line 416... 

    MuffinGroup, your 'quick fix' fixed this - however, I am also having problems - and this obviously needs to be fixed immediately.

    Thanks so much.
  • @webowner001 As we wrote above, this will be fixed this week.
  • HI MuffinGroup,

    Just updated to latest version of the theme version 3.7 = and the menu issue was not yet fixed.

    Please tell me when this will be resolved for all future updates.

    Thank you soooo much.
Sign In or Register to comment.
bedava hesaplar nulled scripts mod apk indir youtube mp3 dönüştürücü