bedava hesaplar nulled scripts mod apk indir youtube mp3 dönüştürücü

Blog posts not loading after theme update

Hi there,

I updated the Theme on this page (https://www.apotheker-helfen.de/) and now the posts don´t load anymore (https://www.apotheker-helfen.de/afrika/wir-unterstuetzen-das-kekeli-maedchen-projekt-in-togo/) allthough in the backend everything seems to be there (https://prnt.sc/133216o).

The theme, all plugins and WP are updated to the newest version, and I also already tried deactivating and reactivating all plugins. Yet nothing helped so far...

... could you please help me out.

Many thanks and best regards,

Daniel

Comments

  • Hello,

    Did you deactivate and activate your plugin immediately or tested if the posts work with plugins disabled?

    Please, activate some free theme like Twenty Twenty, and check if you the posts still open in such way.


    Thanks

  • Hi Phil,

    Thanks for you quick response.

    I´ve done both now – yet the posts don´t appear with all plugins deactivated and don´t show up, when changing to Twenty Twenty Theme...


    It´s totally weird... because, when you go to the home-page (https://www.apotheker-helfen.de/) the posts are there and even deliver the content for the revolution slider.


    Do you have any additional ideas?


    Best regards,

    Daniel

  • If the same issue appears with another theme, then it means that the source problem does not come from Betheme.

    Do you have your main blog page assigned correctly?

    Please, check the following video about how to create and manage and create a blog page, and follow the steps from there:

    https://support.muffingroup.com/video-tutorials/how-to-create-and-manage-a-blog-page/

    Please, also check your permalinks are set up properly in Setting -> Permalinks.


    Thanks

  • Hi Phil,

    thank you for your help – yet that was not solving anything. I had to hire a developer, who found the problem, that I here want to share with you... maybe to improve the last BeTheme update:

    ----------- begin quote --------------

    as already told you on the phone the error is fixed and the blog posts are displayed again.

    See e.g. https://www.apotheker-helfen.de/afrika/unterstuetzung-im-kampf-gegen-malaria/


    Error/cause:

    The problem "empty pages" was not caused by the PHP setting for "max_input_vars" but by the update of "BeTheme" resp. the changes in the file

    /.../wp-content/themes/betheme-child/includes/content-single.php


    Here, two functions are used or called that do not exist and thus generate an error and ultimately nothing comes out.

    They are the functions...

    mfn_opts_show()

    and

    mfn_builder_print()


    We have now "hard coded" this to correct the error.

    If desired and still budget available it would be better to search again more exactly "why and why" with the update in the PHP code function calls come in and these functions in the further code or plugin do not exist. That makes no sense. I do not think that an update is offered, which ultimately does not work or calls functions, which were not integrated. Unless the developer was heavily drunk 😉 

    I suspect that the update did not go through completely or error-free, or you only made an update for a subsection ("betheme-child") of the entire plugin ("betheme") and perhaps a full plugin update with further adjustments would have to be made.

    Possibly there could be further problems and / or even "security gaps", which are currently not apparent. I.e. strictly speaking and cleanly worked you should look at it again. I can not imagine that everyone has to correct after the update in the code "hardcoded".

    You should always read before an update in the change log of the update or the new version what and how has changed and if necessary in addition to the "update click" still to make or check.

    Before you do another update you should always make a backup, because our "hardcoded" corrections will be lost or overwritten.

    ----------- end quote --------------

    It would be great if you could repair the reported bug, so that we don´t have to hire payed developers every time we want to backup the theme.

    And if this really helped you find a mayor problem in the theme... I wouldn´t mind a reward (lets say 2-3 BeTheme free licenses) as this is more or less what I had to spend for the developer to find a problem caused by the Theme itself.


    Looking forward to hear from you.


    Many thanks and best regards,


    Daniel

  • Your developer is right that there was a major change in calling functions. Recent changes in Envato terms & conditions forced us to make some modifications to the theme files. https://help.author.envato.com/hc/en-us/articles/360000481243#h_674316188621522302914837

    One of those changes is replacing 'mfn_opts_show()' to 'echo mfn_opts_get()'. This is why your child's theme did not work after the theme update.

    To make your Child Theme work again, you have to find that function in all of your modified files (in the child theme) and replace the 'mfn_opts_show()' to 'echo mfn_opts_get().'

    Look at the screenshot example to make it more understandable: https://pasteboard.co/IdJyIOZ.jpg

    You must be aware that we do not handle child theme modifications, and you must be careful while editing the files.

    https://support.muffingroup.com/documentation/installation-updates/#child-theme

    Thanks

  • Hi Phil,

    thank you very much for your response and the notice to the child theme support policy.

    Though, if you look at the child theme used in this case, you will see, that we just created the child theme to have a better update performance – we haven´t made any changes to the core of the theme.

    All we did is use external plugins and change some css styles. And according to our developers opinion none of these have an effect on the "mfn_opts_show()' to 'echo mfn_opts_get()".

    So as for me, this error is on your developers – as you also underlined... It can´t be necessary for al child theme users out there to have to change code lines accross the theme... and then face theme with a policy screenshot...


    So far your support has always been very solution oriented... yet this time this is not what I´m used to... and we have some websites running on your theme () I would have expected to have some understanding and a little bit more goodwill, specially after WE are now paying for an error caused in the theme and not by us. ☹️

    Maybe you have a chance to overthink this.

    Looking forward to hear from you.

    Best regards, Daniel



  • Sorry, but we do not support any file modification, even the slightest ones, nor in parent and child theme. We highly recommend not undertaking it if you are not familiar with file customization or have an experienced web developer.

    Even none of your plugins and CSS styles affect the "mfn_opts_show()" function, as you said before, it was causing this problem.

    Here, two functions are used or called that do not exist and thus generate an error and ultimately nothing comes out.

    They are the functions...

    mfn_opts_show()

    and

    mfn_builder_print()

    We did not change it intentionally, but it was imposed on us by Envato, and it could be easily fixed only by replacing this line to and to "echo mfn_opts_get()".


    Best regards

  • Hi Phil,

    I get your point. What I don´t get, is why I HAVE TO PAY A DEVELOPER to get this done, when IT WAS IMPOSED TO YOU by envato.

    The theme was sold over 228,000 times on envato... so everybody using a child theme will have to hire a developer to change this... and I WILL HAVE TO CHANGE IT on all the other 9 BeTheme installations I have running, just because I use (not changed) child themes (specially when you yourself recomend using a child theme: https://support.muffingroup.com/documentation/installation-updates/#child-theme).

    Maybe a patch or a update for everybody that solves this issue would be a good idea...

    Sorry, but this is very dissapointing.

    But thanks anyway.

    Best regards,

    Daniel

  • I am really sorry that this situation occurred.

    We had sent instructions on fixing this problem to everybody that had it when this change appeared, but it was around two years ago. Moreover, you did not state at the beginning that you are using a child theme, and I did not know that the problem could be connected to it.

    Also, it cannot be updated with a patch because every customer has a child theme set in a different way, and we cannot do the blind guessing where that function was used. The child theme must stay untouched by us because it is the whole idea of using it.


    Again, my apologies and best regards

Sign In or Register to comment.
bedava hesaplar nulled scripts mod apk indir youtube mp3 dönüştürücü