Compatibility issue with BeTheme and WP-Rocket

edited January 2023 in Theme support

I have found a compatibility issue with WP-Rocket and Betheme, the 'Visual' and 'Text' buttons don't show (anywhere) in Betheme anymore when using WP-Rocket in combination with a specific setting (see image with example when editing a Column Text).

When the buttons aren't showing, only html code of the item is shown and editable.

Also the add media, shortcode, format etc buttons show differently.

I suspect this might be related to when you have activated the WP-Rocket setting 'Delay javascript execution'. To solve any issues, you can add exclusions to it (examples at:

Can you tell me what specific exclusion one should add to WP-Rocket to get the buttons (and functionality) showing and working again?


  • Hi,

    It is not Betheme related problem but the WP Rocket configuration. You need to add an exclusion for all JS files related to the builder, which can be found in catalog functions/builder/assets.


  • Hi Phil,

    Thanks for the pointer!

    I have tried adding the following as exclusions but that doesn't solve the issue.



    I have contacted WP-Rocket as well.

  • Please, let me know when you answer you back.

    Unfortunately, I do not have access to WP Rocket currently, and I could not check that.

    Best regards

  • No problem, will keep you posted when I learn more from WP-Rocket Support.

  • edited January 2023

    In the meanwhile I have discovered that somehow on Mac, PC, in Chrome, Firefox and Safari, the issue is there, even with WP-Rocket and all other plugns disabled. Then I found that when I login with another admin account, the buttons show ...

    So somehow my own admin account, which used to have the bttons showing, doesn't have the buttons anymore and other admin accounts do see them. Loggin out and in with the account does not solve the problem either.

    I then logged in with another admin account, removed the 'corrupt' admin account and re-created it again; after that I opened a post to edit it, now a popup promoting the new Betheme Builder functionality opened, skipped that and the buttons show again ....

    Problem solved in the end, but the question remains what caused this issue, you have any idea?

  • Do you have any caching tools enabled on your server?

    It could be the root cause.

    Best regards

  • edited January 2023

    Ah, good point, could be the case indeed.

    So basically a corrupted cache of some sort which was deleted and properly re-created again when the new admin account was added, something like that?

  • Most likely, it was like you described.

    If this happens again, please remember the steps you performed, and tell me how to reproduce this issue, so I will check that on my environment.

    Best regards

  • Thanks and I will report when I run into the issue again.

Sign In or Register to comment.