Cannot add new mega menu template


BeTheme won't let me add a new template. When I go to Templates from the left side menu and add a new template, it directs me to the page of "Posts" and the mega menu is not added.

How to solve? Thanks.


  • Hello,

    Please, turn off all of the plugins, refresh your cache, and check if the problem persists.

    Moreover, if you use a child theme, switch to parent, and recheck it.

    If this will not help please send us WordPress dashboard access privately thru the contact form, which is on the right side at, and we will check what might be the reason.


    Please attach a link to this forum discussion.

    Sending incorrect or incomplete data will result in a longer response time.

    Therefore, please make sure that the data you are sending are complete and correct.


  • Hi

    Thanks for the help. Seems like WPML CMS is the culprit. Whenever I disable it, everything works normally also in Templates menu. When I enable WPML plugin, Templates stops working properly and I also get a 500 Error whenever I try to access the website. Now when I rebuild Permalinks, site starts working again.

    Any ideas what should I do?

  • Also my normal sidebar has just randomly disappeared....

  • Hi,

    Please always attach a link to your website so we can check it out. If the page is offline(localhost), then our help will be limited. You will have to contact us when the page is online. Also, please make sure that the page is not under maintenance before you provide us with the link.

    Also, please tell me if the sidebar appears, when WPML is disabled.


  • 1) You should populate with content the "Plugin WooCommerce" sidebar, not the custom one you created.

    2) As I see, you have turned on the WPML CMS and it works fine, can you tell me, is the problem related to "WPML Multilingual CMS" or "WPML CMS Nav"? And also how to reproduce the problem.


  • 1) Thank you. Honestly I have been having online stores for years and this is my first time with BeBuilder. While I like the overall system and would like to start using it for several stores to come, I am struggling at some elements quite badly. For example - where did I go wrong and mess up the sidebar in the first place? Sidebars are in firstly in Widgets, then they are in the Page Template when I open Product Archive page for example, then they are also in Theme Options. I think the documentation is really not helpful enough. Now if I need to use the Plugin Woocommerce sidebar, why is it now popping up on the right hand side and not showing any product attributes although it worked just fine before the trouble started? So ALWAYS the product archive pages only use the Woocommerce sidebar?

    2) It seems to be WPML CMS related. Popping that on and off made a difference.

    To reproduce the 500 Error issue with Template, just go right now to Templates, add a new Mega Menu Template for example. Then it opens BeBuilder and already a 500 Error appears without a possibility to edit it. The only way to fix the site back is go to Permalinks menu and Update.

    I really appreciate your help, I want to use your system but really want to get a good grasp of the design since any of such issues should not occur once we go live.

  • 1) We'll discuss it in office to make it more clear for users - our documentation is already being refreshed because its a little bit outdated.

    Can you tell me an example, which attributes do you have in mind?

    Probably the shop page was not selected in woocommerce settings, after setting it up all prepared options (including that one) are starting to work.

    2) Can you contact the hosting provider and ask him about the logs? It will be really helpful for us and surely it will make the solution of the problem faster.

    I tried to recreate it on my local environment and it does not appear.

    Sorry about the problems you encounter.

    Best Regards

  • 1) Thank you. I would like to use for example the Color attribute on my test product "Adelian T-Shirt" and I would like the filtering to appear on the left hand side of the Product Archive page when going to Men category for example.

    2) Do you mean the Apache Error log? Here are the only things it's outputting:

    [2023-03-17 15:15:28.835806] [vhost:] [core:error] [pid: 47471] [client:] AH00124: Request exceeded the limit of 10 internal redirects due to probable configuration error. Use 'LimitInternalRecursion' to increase the limit if necessary. Use 'LogLevel debug' to get a backtrace.

    [2023-03-17 15:18:00.944817] [vhost:] [core:error] [pid: 48520] [client:] AH00124: Request exceeded the limit of 10 internal redirects due to probable configuration error. Use 'LimitInternalRecursion' to increase the limit if necessary. Use 'LogLevel debug' to get a backtrace.

    [2023-03-17 15:18:00.944833] [vhost:] [core:error] [pid: 48520] [client:] AH00124: Request exceeded the limit of 10 internal redirects due to probable configuration error. Use 'LimitInternalRecursion' to increase the limit if necessary. Use 'LogLevel debug' to get a backtrace.

    By the way right now I am unable to see the store after you did your tests - are you able??

  • Hello,

    1) To set up colors swatches, please, see the following video tutorial:

    About the sidebar, see this one:

    At 2:05, you will see how to set up the position of the sidebar.

    2) To inspect that, we will need access to your FTP. Please send it as you did with dashboard access, and remember to attach a link to this forum discussion.


  • Hi,

    Thanks I am checking these out.

    Have you had any success on the 500 error that appeared? Right now I can see that someone has fixed it but what is the current status? Would be so important to get the error under control when adding a new Template since it can possibly occur with some other functions too, who knows.

    Please let me know if you have any news so we know when we can get back to work on the site. I appreciate your help a lot.

  • As I mentioned in my previous message, to check it properly, we will need your FTP access.

    When you send we will take a look at why it might occur.


  • Sorry, did that. Meanwhile I carried out the following which seemed to currently help with the case but I am not sure this is the right way to do it...

  • Temporarily it seems to be the right way to do it.

    In the upcoming update, we will release a fix that should correct that, so when it is out, please change back this modification, and check if the problem persists.


  • Thank you. I have made a note that I will keep an eye on the updates and then I will remove it accordingly.

Sign In or Register to comment.