DO NOT UPGRADE TO 27.0.x - BeTheme Blocks GONE! No longer able to edit anything!

edited May 2023 in BeBuilder

I've just updated BeTheme from 26.8.5 to 27.0.1 and I've found that BeTheme Blocks have gone and forced into using Live! Having tried to edit something and update, it just spins forever and never updates the page.

I found an option to switch back to BeTheme Blocks but when I do I now just see a blank page when I edit anything!

It's a load of rubbish what you have done now!

The only way I can continue is to restore last night's backup!

It's also a rip-off that I had to pay $42 just to make this report to you regarding this massive bug in BeThemes.

Please can you put back BeTheme Blocks as it was? BeTHeme Live is a load of rubbish is makes our pages completely uneditable.



  • This needs to be fixed ASAP!

  • Yes, the same thing is happening to me (I thought I left a post earlier, but it is gone now...). I was able to go to a backup of my website that had the previous version 26.8.5, but it is frustrating that BeTheme updated to a version that is not working.

  • Hello,

    We found the root cause, and it will be fixed in the upcoming update, which we hope to release today.

    For now, please enable BeBuilder visibility to Everyone in theme options.

    Furthermore, by editing the page like before, we clarified that the Blocks is now a part of the BeBuilder in a very short video. All you have to do is click on that link so the video can pop up. In case you missed it somehow, we have attached the screenshot below.

    Best regards

  • I have to say I DO NOT LIKE it and wished that you have kept BeTheme Blocks as it was! Everything is so slow now having to go into BeTheme Live! This is very much a step backward IMO. The option to use BeTheme blocks or Live should be a global one outside of BeTheme Live! Please reconsider, you have affected hundreds of your customers with this change.

  • @thecovertformula,

    The blocks you are talking about, previously known as Muffin Builder, were created over ten years ago. The technology they were written is outdated and does not meet today's standards. Building websites is now much more advanced, and the number of options needed to build them, such as the ability to customize the appearance of the website on mobile devices, is enormous. Unfortunately, a huge part of user pages could not be loaded correctly with this technology, so we had to improve it according to the users' wishes. Technology is relentlessly moving forward, and we have no choice but to adapt.

    Despite the above, we ensured backward compatibility, and Blocks are available in the same form as before, but due to the new technology in which they were written, they are now much lighter and faster. So as you can see, there are only benefits of such a solution.

    Best regards

  • At the moment it's not lighter or faster for me, so I will await the new update and see if it improves. But I do not like it, it all seems very clunky and everything is now in a different place as it was before.

  • Please send us WordPress dashboard access privately thru the contact form, which is on the right side at, and we will check what might be the reason. Please also tell me what parts are "clunky".


    Please attach a link to this forum discussion.

    Sending incorrect or incomplete data will result in a longer response time.

    Therefore, please ensure that the data you are sending is complete and correct.

    Moreover, we did not move settings in the compression to the previous location of BeBuilder Blocks. The only difference now is that settings do not open in the popup but are available on the left panel.


  • I've gone back to a previous backup for now so it's all working at 26.8.3 as we have lots of updates that need to be done - once you have released 27.0.2 I will try again and if I still have issues I will use the link above.

    When I say "clunky" - this is what I mean... before when I edited the page everything was there ready for me to edit in blocks and all other features on the right. Now I've got to go into another editor separate from the WP page where now I am seeing the page live and not in blocks. This is going to be tricky for us and would be better if we can set the blocks option before going into the live editor. The reason for this is we have security scripts that should only be run on a live site and running them in an editor for us is very dangerous.

    The other reason for "clunky" is that before everything seemed intuitive and was very easy to use and make changes quickly. Now, it's like we have got to learn another new system on how to edit our pages and apps as it seems like everything we knew before, we have now got to find where you have moved that option/settings too.

  • Same here! Followed the tips on the video "If you go for a classic look but want an extremely fast builder check this video"

    But the opposite happened. Extremely slow! If this stays I have to find another theme. I can't sell this to my customers.

  • We would be thankful if you write your suggestions on how to improve the use BeBuilder on the following topic:

    However, regarding your last paragraph, as I mentioned before, settings were not moved anywhere, they just appear on the left panel instead of a popup.

    Please send us WordPress dashboard access privately thru the contact form, which is on the right side at, and we will check what might be the reason. Please also tell us what exactly you refer to: BeBuilder, theme options, or anything else.


    Please attach a link to this forum discussion.

    Sending incorrect or incomplete data will result in a longer response time.

    Therefore, please ensure that the data you are sending is complete and correct.


  • Hey Muffin Group, found a solution, and you may want to share.

    OK, I was able to change the settings to show Builder Mode and change to Blocks, but It is still not updating...just get the swirl of endless update. And yes, I have refreshed, logged out, and cleared cache, etc.

    So I changed my Wordfence firewall settings to "Disabled", then "Learning Mode', then "Enabled and Protecting". It is working now and I am able to save and update! I have noticed that I need to clear the cache after each update for the changes to show, but that may just be my settings.


  • Hi, thecovertformula

    You right I also have problem with this version as you can see in this post :

    For the moment no solution ! I'm thinking of downgrade to the previous version...

  • @stephpixels I have sent you several videos yesterday showing you that the issue you've faced has nothing to with the theme itself. The problem is on your end and like explained, problem might be with things like adblocks, 3rd party plugins, cache, outdated browser, etc. We have checked your site on 10 different computers with different specs, config, browsers and on each theme options loads fast.

  • There is a ghost in my computer ;-)

    This morning is working fine. I just test after desactivated all Firefox plugins and reactivated one by one. No problem.

    Very very strange. It's like the problem come after hours of working on WP.

    Thanks anyway.

  • @stephpixels In 99.9% of cases, this ghost is called cache ;) That's why, whenever you face weird looking issue, it's always so important to:

    1. Disable all 3rd party plugins
    2. Disable cache (no matter if it's 3rd party plugin or server side tool)
    3. Make sure theme is up to date

    Anyway, glad to hear that cache on your end have cleared and all works fine again :)

  • edited May 2023

    There also seems to be problem with the Header Creative Open and the BEBuilder Templates e.g. Header Builder - where it shows a masked version of the homepage of the website when you create a new template and it is impossible to drag and drop elements and keep them visible while working. Perhaps a z-index problem? Works fine on other sites with top menu but not with any side menus.

    Has anyone had this problem?

  • Hi @247webmaster,

    With different problems, creating a new topic about it and attaching a link to your website and screenshots showing that is recommended.

    However, if you mean that header creative appears on the header template, I was able to reproduce that, and passed it to the dev team to correct it.

    Best regards

  • In my case, the plug-in that broke things for me after the update was “WP All Export”

    Hope this saves time/helps someone looking for a quick fix.

Sign In or Register to comment.