Blog Content not populated


I followed the instructions on your docs and video tutorial (create new page, empty, standard template, set wp read settings to static page, configure betheme blog options, add the new page to menu), but the blog posts do not populate, the page keeps empty.

Previously, i tried to set up an own blog template, that worked, but now i want to try the hardcoded layouts, so i deleted this template. I even did a complete reset, but that didn't help either.

What I'm doing wrong? Or is it a bug?

Thanks, and best regards


  • Hi,

    Please always attach a link to your website so we can check it out. If the page is offline(localhost), then our help will be limited. You will have to contact us when the page is online. Also, please make sure that the page is not under maintenance before you provide us with the link.

    It is always a good idea to also attach a screenshot showing your issue.


  • edited November 2023


    thanks for your response. I'm not sure how it could help if you see that there is nothing to see. But you might want to analyse the html source? I made a strip-down copy of the page, with only two pages: startPage and mediccoo-blog. Last one should populate the blog items, but there ist no content at all. I did a reset on betheme and exactly followed your video tutorial for creating the blog.

    ---> user/pass: beforum/betest

    I assume this issue is somehow related to the fact that i previously ceated a blog template and deleted it afterwards. Maybe Betheme does not fully delete all information related to this template, i guess the default internal template was overwritten and not restored on deletion of my own template. Should I be right, one solution would be to not overwrite the internal template by user templates, but to overload them.

    If it helps, here are screenshots of my setttings:

    Best regards


  • Just as additional note: A similar problem seems to exist with the header builder. After deletion of the header template, there are still some settings active that are not accessible within the standard theme options. E.g. the height of the header that was set in the header template.

  • Hi,

    We have found the root cause, and the fix will be available in the upcoming update.

    If you want us to correct it on your website earlier, please send us the WordPress dashboard and FTP access privately thru the contact form, which is on the right side at


    Please attach a link to this forum discussion.

    Sending incorrect or incomplete data will result in a longer response time.

    Therefore, please ensure that the data you send are complete and correct.


Sign In or Register to comment.