BeBuilder Stuck on Loading Page Content

Hi guys,

My BeBuilder is stuck on loading page content and will not progress any further than that.

Can you please assist me in fixing this? I have sent you a message on envato with my details for logging in and give you my permission.



  • I just bought the theme and was trying it out, and ran into this issue as well. But, I've fixed it on my server.

    I believe it's related to your PHP config. Check BeTheme's reported System Status at:


    Mine had some warning for PHP Time Limit, PHP Max Input Vars, cURL, and ZipArchive.

    I had to install the PHP extensions zip and curl for my server. The time limit and max input vars were settings I had to change in my PHP config (php.ini). Now that I've fixed those and the "System Status" is looking all green, I can pull up the BeBuilder.

    I'm not going to go into details on how to fix the above because it can vary greatly from server to server. Plus, since I think most people use a wordpress hosting provider, you likely don't have access to install PHP plugins or update your PHP config; your hosting provider would have to do this for you. (One of the benefits of self-hosting!)

  • Hi @KTKProperty_,

    Did you receive an answer from us through email? I do not manage the mailbox (there is another person in charge of it) and I do not know if your problem was resolved or not.

    Thanks @davida162 for suggestion how to resolve that. Hope it helped OP or anyone else who visits this topic.

    Best regards

  • Hi guys.

    The other guy who works with you fixed my issue and said it is being fixed in your next release which is good news. The support for this theme is impressive, very happy with it.


  • It's great to see that my colleague resolved your problem.

    And we are happy to see that you are satisfied with our help. Always happy to see such kind words.

    Best regards

  • Hey @Phil, it looks like I'm encountering this issue still (not OP - but it's the same symptom). I thought I had fixed the issue after changing some PHP settings per the BeTheme status page recommendations, but I guess not!

    I have setup a sandbox site on my home server and I've restored a backup of my actual production site to this sandbox, specifically so I could test Betheme out.

    On my sandbox site, when I view a page and then click "Edit with BeBuilder" at the top, the page gets stuck on "loading page content...". In the browser console, I see the following traceback:


    Uncaught DOMException: Permission denied to access property "addEventListener" on cross-origin object
        jQuery 2


    Uncaught DOMException: Failed to read a named property 'addEventListener' from 'Window': Blocked a frame with origin "" from accessing a cross-origin frame.
        at Object.init (
        at HTMLIFrameElement.<anonymous> (
        at HTMLIFrameElement.dispatch (,jquery-migrate,hoverIntent,utils,wp-polyfill-inert,regenerator-runtime,wp-polyfill,wp-hooks&ver=6.4.1:2:40035)
        at v.handle (,jquery-migrate,hoverIntent,utils,wp-polyfill-inert,regenerator-runtime,wp-polyfill,wp-hooks&ver=6.4.1:2:38006)
  is the private IP of my sandbox server where this site is running. I'm not sure why it's detecting a cross origin request. Any ideas on what I can check? I'm wondering if maybe it's certificate related as I'm using the signed certificate from my production site on the sandbox server which is obviously invalid.

    I've enabled wordpress debugging and don't see anything from the PHP side so I'm pretty sure the culprit is the JS traceback I've shared above.

  • Hi @davida162,

    It is because of Cross Origin Policy, and you must allow loading frames because the server is blocking iframes.

    Best regards

  • Thanks Phil! That pointed me in the right direction. I started looking into the request headers surrounding the iframe object, and I already saw Access-Control-Allow-Origin: * was in the server's response, so I kept digging.

    It turns out it was actually due to my web server having Header always set X-Frame-Options DENY set in /etc/apache2/conf-available/ssl-params.conf.

    I updated the config to Header always set X-Frame-Options SAMEORIGIN and this fixed the issue. I can now get to BeBuilder.

  • Thanks for letting me know, and it's great that you handled it.

    If I can help with anything else, please let me know.

    Best regards

Sign In or Register to comment.