Random Post On Pages Following Redirect

Hi guys,

When you visit the homepage of the website tradesgetbusier.com & click any of the services icons such as paving for the redirect, there is a different section which appears at the top and is completely unrelated.

How can I stop this showing? It does not show when you directly visit the pages in the menu or link without getting redirected.


Comments

  • Hi,

    Edit the post, and change the template to Builder in the Post Options.

    Best regards

  • Hi Peter,

    This is not an option on my pages. Please see screenshots of my page options attached to the post.

    Any ideas?


  • Is not a post what you show on a screenshot?

    Please send us the WordPress dashboard access privately through the contact form, which is on the right side at http://themeforest.net/user/muffingroup#contact, and we will check that.

    Notice!

    Please attach a link to this forum discussion.

    Sending incorrect or incomplete data will result in a longer response time.

    Therefore, please ensure that the data you send are complete and correct.

    Thanks


    PS.

    It is Phil, not Peter 😅

  • edited November 2023

    Phil my apologies!

    I have sent you guys another contact form with all links included on Envato. Can you please take a look at this ASAP as I can't understand it.

    You can visit the website and recreate the issue for yourself.

    1. Click here - https://tradesgetbusier.com/
    2. Scroll down to the 'services' section with black background
    3. Click on any services
    4. You will see the redirect makes this post appear at the top of the screen (photo attached)

    This is all the page options I have at the moment


    Thanks,

    Kurtis.

  • Elementor causes it. As soon as I disable it, the layout is correct.

    By default, before the page address, there should be a parent page displayed. Even if someone types by hand a link to this page and forgets about the parent page, it should be auto-filled.

    When Elementor is active, the parent page in the URL is not added, and the layout breaks and is not as it should be. I checked it on the Twenty Twenty-Four theme to ensure that it is not related to Betheme:

    You have two options:

    1) If you do not use Elementor, you can remove it and do not worry about this issue.

    2) Contact the Elementor support and report this problem.


    Best regards

  • Thank you for finding this out - I've just deactivated the Elementor plugin.

Sign In or Register to comment.