I can not change font, every time I try and click Save the old font remains.

I click on Save in theme options and then regenerate fonts

I have enabled cache local, can you please check ?


  • Hello,

    Please turn off all of the plugins, refresh your cache, and check if the problem persists.

    Moreover, if you use a child theme, switch to parent, and recheck it.


  • Hi, I tried all you mention, but problem remains. can I send details?

  • Sure, please send us the WordPress dashboard and FTP access privately through the contact form, which is on the right side at and we will check what might be the reason.


    Please attach a link to this forum discussion.

    Sending incorrect or incomplete data will result in a longer response time.

    Therefore, please ensure that the data you send are complete and correct.


  • For a test, I changed the font in the menu, and everything worked correctly.

    Are there any extra steps to reproduce your issue?

    Best regards

  • Please login to the wp admin (thats why I send login details) and you will see that fonts cant be changed if you go to Theme Options , try to change font

    in the content there is Alegreya (which I want to enable on site) and on frontend font is not changed, I try all you said

    Please let me know how to resolve this issue,

  • Just checked and everything works seamless. I really beg you to disable CACHING when working on site. What's the point to use CACHE when you are editing site? This really brings more harm than good. We attach screenshots showing that everything works as it supposed to work.

Sign In or Register to comment.