Issues with Mega Menu and Product Alignment on Category Pages

Dear BeTheme Support Team,

I hope this message finds you well. Currently, I am encountering two issues with my BeTheme implementation and would appreciate your assistance in resolving them:

  1. Mega Menu on Category Pages: The mega menu intermittently fails to appear on category pages, and when it does, clicking on main links from the dropdown opens a different page instead of the intended one.
  2. Product Title and Price Alignment: On category pages, the alignment of product titles and prices appears inconsistent (zig-zag), despite appearing correctly in the BeBuilder preview.

These issues significantly impact the user experience on my website. To improve this, I am looking for CSS solutions to ensure each product title occupies two lines or leaves one line blank if shorter, with the price centered below it. This approach will prevent the titles and prices from appearing disjointed.

Could you please provide guidance or updates to address these concerns promptly?

Thank you for your attention to this matter. I eagerly await your response and resolution.

Comments

  • Hi,

    Please always attach a link to your website so we can check it out. If the page is offline(localhost), then our help will be limited. You will have to contact us when the page is online. Also, please make sure that the page is not under maintenance before you provide us with the link.

    It is always a good idea to also attach a screenshot showing your issue.

    Thanks

  • my website is live not on localhost


    here is the link of my web

    https://suitsyourself.online

  • i want to share my web credentials with you guys kindly tell me the secure way for that purpose


    Thanks

  • 1) I have checked your mega menu on the category, and it opens correctly.

    Also, all links work correctly.

    2) Please attach a screenshot showing what you refer to.


    Thanks

  • I am experiencing several issues with my website related to the BeTheme. For instance, sometimes the menus open on the category page, and other times they do not. Additionally, the links on the category pages sometimes work correctly, while other times they lead to incorrect pages. Furthermore, the main image on the category page occasionally displays, but sometimes it does not. I am unsure what the issue is and would appreciate it if you could take a look and resolve it.

    Moreover, I would like to know how I can safely share my website credentials with you. Additionally, as we previously discussed, I need each product title on my category page to occupy two lines, even if the title fits within one line. This is because some product titles currently display on two lines while others are on a single line, causing the prices to appear in a zig-zag pattern. Ensuring that each product title occupies two lines will make the display more orderly, modern, and professional.

    I am also attaching two images of the shirt category page for your reference. You can see that the heading images are displayed differently and sometimes do not appear at all.

    Currently, I am referring specifically to the 'For Men' category, not the 'For Women' category. Please focus on this section, as the links are opening incorrectly despite being set up differently. I urgently need your help with these issues and would be very grateful if you could assist me in resolving them.

    Additionally, I have attached an image where you can see that the button color was set to something else, but after updating the theme, the hover color shows as grey. I have checked all my CSS, JS files, and even disabled plugins, but the issue persists. Kindly look into this matter as well to help resolve it.

    Thank you for your assistance.


  • To summarize, here are the main issues I need assistance with:

    1. Menu and link functionality on the 'For Men' category page.
    2. Consistent display of main images on the category page.
    3. Ensuring each product title occupies two lines for a uniform display.
    4. Resolving the button hover color issue post-theme update.
  • 1, 3) I tried my best to understand and notice your issue, but unfortunately, I was still without luck. Can you please record a brief video showing your problem?

    2, 4) Please send us the WordPress dashboard access privately through the contact form, which is on the right side at https://themeforest.net/user/muffingroup#contact and we will check what might be the reason.

    Notice!

    Please attach a link to this forum discussion.

    Sending incorrect or incomplete data will result in a longer response time.

    Therefore, please ensure that the data you send are complete and correct.

    Thanks

  • no worries buddy i will make a video for you regarding that issues which i am facing and will send you soon but yea i have already sent you the credentials of my web kindly check that

  • 1, 3) Did you create the video for me?

    2) I checked that, and images are exactly the ones that you set in the templates. Should I check some specific category?

    4) In theme options, there was information that there was an update regarding buttons, and saving theme options is required to regenerate static CSS. I did that, and the buttons seem to be fine.


    Best regards

  • Hello dear,

    Could you please clarify which "Regenerate CSS" option you utilized? I would appreciate an explanation of how you concluded that the issue was resolved, as the problem appears to persist. I have attached an image for your reference, allowing you to verify the ongoing issue.

    Thank you for your attention to this matter.

  • I opened theme options and saved them.

    Where can I find the button from your screenshot? I tried to locate it before but without luck.


    Thanks

  • Dear you can open any product page and there you can find that button and you can compare that with the screenshot if you have doubt after that


    thanks

  • I am writing to formally request your professional assistance with an issue I have been facing for several days. Despite my previous communications, the matter remains unresolved.

    Attached, you will find an image illustrating the specific issue: I need the price to be centered and each product to occupy two lines. This visual representation should provide clarity on the changes I am seeking.

    I kindly urge you to address this matter with the professionalism and expertise I trust your team possesses. Your prompt and thorough support in resolving this issue would be greatly appreciated.

    Thank you for your attention to this request.


    Thanks

  • 1) The product button styles are modified by one of your plugins. This is how it looks after I disabled all plugins but the ones we support:

    To find the ones that changes it disable your plugins one by one, and when you find the culprit, contact the plugin author regarding this.

    2) To center the text you must edit the shop template open Shop Products element, and set Text align in the Conteiner to Center.

    3) If you want the title to always display in two lines you must tighten the space in the title area by adding some margin on the sides or by increasing the font size.

    Best regards

  • Dear Support Team,

    I truly appreciate your prompt and considerate response to my previous query. However, the issue with the title alignment still persists. As you can observe in the attached image, titles that are longer appear correctly in two lines. However, titles with shorter lengths disrupt the alignment, resulting in a zigzag appearance of the prices, which is not the desired outcome. I kindly request your assistance in resolving this issue or guiding me on how to achieve a consistent alignment.

    Additionally, you mentioned the deactivation of a plugin that resolved the button display issue. Despite my efforts to deactivate all plugins, I could not replicate the fix. Could you please specify which plugin you deactivated so that I can address this matter effectively?





    Thank you for your continuous support and guidance. I look forward to your response.

  • 1) Did you add side margins to the title or increase the font size as I suggested? You have many shop templates, are you sure you edited the correct one?

    2) I disabled all plugins besides the ones we support, so I do not know which was the root cause. Did you disable all plugins (except basic WooCommerce) individually?


    Best regards

  • template and checked the updates on it, but no changes appeared. Could you kindly demonstrate the correct implementation on one template so that I can follow the same process for the rest?

    Secondly, I am facing another issue. As you know, there are two menus shown in the header, left and right. However, when my website is accessed on a mobile device, only the left-side menu appears in the hamburger menu, while the right-side menu remains outside the hamburger icon. I want both menus to be displayed inside the hamburger menu.

    I will look into the button issues further by disabling additional plugins.

    I would be very grateful for your guidance on these matters.

    Thank you.

  • 1) You did not adjust it for your needs. I gave 50px as an example, but you should adjust this value to suit you.

    I have changed it to 12% now. Please check it out:

    2) You must create a new mobile menu in Appearance -> Menus and set it in the mobile display.

    https://support.muffingroup.com/video-tutorials/building-mobile-headers/

    Best regards

  • Hello Dear,

    I have two different menus: one for the main menu and another for a secondary menu. I want both menus to be shown in the hamburger menu. As you can see in the screenshot, only one menu is currently displaying in the hamburger menu, not both. Is it possible to show both menus? If so, could you please guide me on how to achieve this?

    Thanks.


  • As I mentioned before, you must create a new menu for mobile display and combine these two from desktop to have links you need.

    You can also use the Sidebar menu builder.

    https://support.muffingroup.com/video-tutorials/sidebar-menu-vertical-header-builder/


    Best regards

  • Hello Support,

    I have created a new menu named "suitsyourselfmobilemenu." Could you please add it as demonstrated in your last response? I would be very grateful to you.

    Thanks,

  • It would be better if you do it by yourself. 😉

    Open your header template, select mobile display, choose hamburger menu, and select your menu there:

    Also you can hide this menu for mobile:

    Best regards

  • Hello Support,

    I would like to know if there is any functionality in Betheme that can differentiate the design and look for online users and offline users. Currently, on my website, something works perfectly when I am logged into my admin panel, but the same thing does not work, or even come close, when I am not logged in to the admin panel. Kindly check and let me know what this is about and how to resolve it.

    Thank you.

  • If your website differs for logged and not logged users, most likely, it means that the root cause is the cache.

    Please ensure that you do not have any caching plugin active or tool enabled on your server.


    Best regards

Sign In or Register to comment.