Problem with the "parallax effect" and the "background image positioning" on "mobile devices".


I have a problem with the "parallax effect" in all known mobile browsers (Firefox, Edge, Chrome etc.).

I only have this problem after updating the theme to version 27.5

The settings in "BeBuilder" under the "Background" tab for "Desktop" are correct.

  • image = (img_1920x1080px.jpg)
  • Repeat = No repeat
  • Position = Center Center
  • Attachment = Parallax
  • Size = Standard

If I look at the result on the smartphone/tablet with different browsers, the "Position: Center Center" is not adopted. The background image moves to the right every time and remains in this position. Changing the position only for mobile devices does not work with any settings. In BeBuilder it is changed and displayed correctly, but not in any mobile browser.

Below is the link to the website.

I therefore ask for your help.

Best regards


  • Hey,

    Please send us the WordPress dashboard and FTP access privately through the contact form, which is on the right side at and we will check what might be the reason.


    Please attach a link to this forum discussion.

    Sending incorrect or incomplete data will result in a longer response time.

    Therefore, please ensure that the data you send are complete and correct.


  • Hi!

    I have just sent all the login details via the contact form.

    best regards

  • We have corrected it.

    Please check it out.

    Best regards

  • Hi!

    Thank you for looking into the problem.

    What settings did you make exactly?

    Kind regards

  • Hello again!

    I have looked at your modification again.

    The settings under the tab: Performance > Minify > CSS + JS from enable to disable do not solve the problem.

    Please log in again with the data I sent you. Then take a look at the Start page with the BeBuilder preview for tablet and mobile. The way it looks in the BeBuilder-preview, is how it should look in real life on mobile devices. But it does not. The background image is not adjusted on mobile devices. I only see partial sections of the image.

    If I specify additional settings for tablet or mobile only, these are not applied when saving. No matter what settings I make for the background image, they have no effect.

    Another example:

    The background image should have the parallax effect on the desktop. But not on mobile devices. There, the background image should be positioned exactly as in the BeBuilder-preview. This does not work. The parallax-effect is not deactivated on mobile devices if it is activated for the desktop.

    Therefore I ask you again for help.

    I have only had this problem since updating to the current betheme version 27.5 and I have not made any changes.

    Best regards

  • Parallax has never worked with the position setting, nor was it a responsive setting. We forgot to add a notification about that. However, it will be added in the upcoming update.

    To hide the parallax effect for the section on tablet or mobile view, you must create a copy of the section for tablet or mobile and disable parallax completely there.

    Also, the parallax effect in BeBuilder is disabled because it generated a couple of issues. However, it is visible correctly on the live page.

    Best regards

Sign In or Register to comment.