Yoast SEO Duplicating Site Name in Page Titles

Hi all.

I'm having issues with Yoast's SEO plug-in adding the site name to all page titles. I have:
  • Removed %%sitename%% from Pages in Yoast > Titles & Metas > Post Types
  • Set "Use built-in fields" to 'No' in Be Theme > SEO > General

The sitename is butted right up against the rest of the page title - no separator or space.

Any advice would be appreciated.


  • Hi,

    site title may come from Settings > General section as well.
  • When I use yoast with this theme muffin builder content it says the content is empty which is scaring me into thinking google will see or NOT see the content!
  • @dbl07 Google will see the content. Only Yoast doesn't see it because you did not used Builder >> SEO option which was created especially for that kind of stuff. More details about this option you can read on http://forum.muffingroup.com/betheme/discussion/1080/search-results-don-t-take-care-of-shortcode-content
  • I am having the same issue (site name getting duplicated on page titles without any separator/space), but it doesn't appear to be Yoast-related. The only way I've been able to get rid of this is to remove the site title from Settings > General, which isn't a viable long-term approach. As with other issues I've encountered, this seems to be a BeTheme issue as it does not occur when other themes are active. Any insights on how to permanently address this would be greatly appreciated.

    Thanks in advance!

  • @smw1357 Some people are using title under Settings > General section so we can not remove it because 1 or 2 people want it. Like we wrote, if you are using Yoast, you shouldn't use title which is under Settings > General section and also built-in seo fields should be turned off. Different users got different needs and we must do the options for all of them.
  • OK, and that's an odd workaround that I've never seen in any of the other themes I've used (and I use Yoast SEO on all of them).

    For anyone else having this issue, if you do remove the site name from Settings > General, then you must manually add it back into Yoast (in the Website Name field under the Your Info tab). Because Yoast pulls the website name from Settings > General, if you delete it there the Yoast field goes blank as well.

  • If you're using Yoast, try this:

    Go into Yoast > Titles and Meta > and then check the box beside "Enable force rewrite titles".

    I left the site name in general settings as it should be, and mine now works correctly. Hope it works for you.
  • edited December 2015
    I had the problem too. Looks so stupid in google search results.
    I did as u said terrywmu (thx mate!) and now when looking into page sourcecode <title>Is as it should be and not doubled</title>
    Up to now google still shows title doubled... I re-indexed it via google search console, so hopefully it´ll soon be gone... 
    Anyone know how long that might take?
  • @lapries We have no influence on Google so we don't know how long time this may take. We can only tell you that sometimes it may be 1-3 days but sometimes week. There is no estimated time. However, if everything is fine in the code, you must wait for Google bots now.
  • Yeah one day later it was as it should be! ;-)

    thanks again terrywmu!
  • @lapries We're glad to hear that all is fine :)
  • I have the same problem but only in multisite. The same configuration on other projects works fine. So I assume is something related between betheme, yoast and multisites because on other sites of the same network with other theme, the title looks fine.
  • @monstreboo Under Yoast > Titles and Meta you should check the box beside "Enable force rewrite titles". Try to do this and check if this would help because we don't know what else might be wrong. If not, switch to default WP theme and check how it works with the default one.
  • It's checked in all my projects but in betheme on multisite it doesn't work
  • @monstreboo Please send us private message with more details and dashboard and FTP access so we can check it ourselves.
  • muffingroup I can't give acces to the ftp because it's only accesible in house.
  • If you can't then we won't be able to help because we tested it on our side and all works fine. The problem must be somewhere on FTP.
  • same project testest on localhost and other servers. Doesn't work.
Sign In or Register to comment.