Custom Category Template

I create the custom template and when I view it, it shows up good. I go to that Product Category and it's just full sized with no template. I'm not sure if it's a permalink issue. I've tried turning off all my plugins. I tried different permalink settings. (maybe still. not the right one)


  • Hi,

    Please always attach a link to your website so we can check it out. If the page is offline(localhost), then our help will be limited. You will have to contact us when the page is online. Also, please make sure that the page is not under maintenance before you provide us with the link.

    It is always a good idea to also attach a screenshot showing your issue.


  • Somehow it's working now. I didn't do anything different

  • But now that you are here. Is there a way to customize the Search Results page? I can't seem to find any documentation on it when I search.

  • Please go to Betheme -> Theme options -> Search -> Page, and there you will find the customization option.

    Best regards

  • again. The template stopped working again. Not sure why it's glitching like that. I'll send photos. (Read from last one up) or you can go to my website

  • I took off the -category GOTTA LMAO exemption and made no difference. Just so you know my intentions, I am trying to put a paragraph underneath the product category so that's why i created a separate template for it. It didn't work when i started building it (followed instructions on YouTube channel) Then after it was live, I decided to try it again as it bothers me that such an important feature doesn't work. And now 'out of the blue' it stopped working. Not sure why it's not implementing the template. If you go to my live site, I had to use the regular template so that my live version doesn't look like it does up there. But the main issue is that the template isn't working.

  • There is a bug in the theme files that causes this issue.

    It will be resolved in the next update.

    If you want us to fix it on your website before an update, please send us the WordPress dashboard and FTP access privately thru the contact form, which is on the right side at


    Please attach a link to this forum discussion.


  • If the update is in the next little bit...I can wait as it's just a paragraph. That'll be fantastic that it will be fixed so I can create more templates with confidence. Thanks for your attention to the matter. Much appreciated. I await the update! :)

  • The update should be this week if we do not encounter any obstacles.

    Best regards

  • With this new update, the masonry effect isn't working. The reason I wanted the template fixed was so that I could keep the masonry style, otherwise I could have just created a new page and added my category to it. The blog part works but the masonry within the categories no longer works properly or am I missing something? It was working before this update.

  • Also the widgets, my "menu" of categories, is not working as well and they were also working as well. These were working prior to the update as well. Not working, as in, when I test them out, some don't work with clicking on it (like there's no link attached), some I have to double click. This is the categorie widget.

  • 1) I could reproduce this problem in my environment and have passed it to the dev team. So we will take a closer look at it.

    2) Do you mean this menu?:

    I have checked it, and it seems to work. What browser are you using?

    Best regards

  • edited October 2022

    I was using in Chrome. I just tried in Safari and I have to double-click on it for it to change. Is there a setting for that? In Chrome, sometimes i double click and it doesn't work. This is with the category with the subcategories as well...whereas before, everything was running smoothly with one click, no matter what I pressed.

  • Please, turn off all of the plugins, refresh your cache, and check if the problem persists.

    Moreover, if you use a child theme, switch to parent, and recheck it.


  • I've done what you requested. I actually found out that I wasn't using the child theme so I had to change it to that. I copied over my style.css and function.php to my child theme so that when I update I dont' lose anything.

    Either way, I haven't changed anything for this to be happening except that I updated the theme and that's when the widget stopped working properly. Double clicking or triple clicking is the only way to get the category widget to work. Right now I could be getting people coming to my website not thinking it works.

  • And not sure if this will help, but it seems to be working fine on mobile but the double, triple clicking is only a problem on desktop.

  • I use Chrome on my iphone as well. I tried it in Safari and the same thing, the widget categories work properly on mobile but not on desktop.

  • There is a new version of Betheme. Please update it, and check if the problem persists.

    If this will not help please send us the WordPress dashboard and FTP access privately thru the contact form, which is on the right side at and we will check what might be the reason.


    Please attach a link to this forum discussion.


  • The login credentials you have sent to the Dashboard are not working.

    However, we manage to reproduce this issue in our environment. As the FTP you have sent is working, we will put the fix for that on your website.


  • Can you resend your dashboard access, please?

    We will actually need it anyway.

    Can we also update Betheme on your website?

    Best regards

  • We fixed that on your website.

    This fix will be also included in the next update.

    Best regards

Sign In or Register to comment.